Project

General

Profile

Bug #8018

Course created in learning path does not appear.

Added by Tomas Rodrigues almost 4 years ago. Updated almost 4 years ago.

Status:
Bug resolved
Priority:
Normal
Category:
Learning paths / Lecciones
Target version:
Start date:
27/12/2015
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

HI.
In chamilo 1.10.2. updated.
Or even a new instaão.
This with a bug when creating a lesson learning.
Once ready does not show the course created.
tested also in:
https://unstable.chamilo.org/

History

#1

Updated by Yannick Warnier almost 4 years ago

Are you sure your .htaccess file in the root folder is the latest one from Chamilo?

#2

Updated by Tomas Rodrigues almost 4 years ago

Hi.
Yeah, sure, I downloaded the new version of Thurs.
https://chamilo.org/chamilo-lms/
Even the fresh installation has this problem.
I just created an ongoing:
https://unstable.chamilo.org/courses/LEARNINGPATHBRAZIL/index.php
Name Learning Path Brazil.
Same problem I'm faced.

#3

Updated by iban goenaga almost 4 years ago

I reproduce the problem and it's only on the creation of page / activity that the content is not saved. On the update it get save correctly.

#4

Updated by Tomas Rodrigues almost 4 years ago

Hi.
You could solve?
I've tried everything I've done other fresh installations.
Nothing, does not appear to me the course created.

#5

Updated by Tomas Rodrigues almost 4 years ago

Hi.
By leaving the mode:
Test server.
It gives this error:

Notice: Uninitialized string offset: 0 in /home/public_html/chamilo/main/newscorm/learnpath.class.php on line 5942

Notice: Uninitialized string offset: 0 in /home/public_html/chamilo/main/newscorm/learnpath.class.php on line 5944

Warning: Cannot modify header information - headers already sent by (output started at /home/public_html/chamilo/main/newscorm/learnpath.class.php:5942) in /home/public_html/chamilo/main/newscorm/lp_controller.php on line 431

#6

Updated by Yannick Warnier almost 4 years ago

  • Status changed from New to Needs testing
  • Assignee set to Tomas Rodrigues
  • % Done changed from 0 to 70
#7

Updated by Tomas Rodrigues almost 4 years ago

  • File learnpath.class.jpg added

Hello.
Unfortunately for me it does not.
I changed the file. I cleared the cache.
In test mode appeared this error:

Notice: Uninitialized string offset: -1 in /home/public_html/main/newscorm/learnpath.class.php on line 5483

Warning: Can not modify header information - headers already sent by (output started at /home/public_html/main/newscorm/learnpath.class.php:5483) in / home /public_html /main / news with / lp Controller.php on line 431
Now.
I went up to the server the file "learnpath.class.php" the chamilo version 1.10.0. to chamilo/main/newscorm/
It works, but it changes the icons of navigation, goes off designer.
image attached

#8

Updated by iban goenaga almost 4 years ago

Hi.

Yannick fix wasn’t working for me too (apart from removing some notices).
I made one change, don't know if it's the way to do it but it's working for me.
The pull request is here: https://github.com/chamilo/chamilo-lms/pull/975

#9

Updated by Tomas Rodrigues almost 4 years ago

  • File comparative.jpg added

Hi.
I replaced the original file:
main / Newscom / learnpath.class.php
This one:
$ content = isset ($ content)? $ content: $ _POST ['content_lp'];
Per:
$ content =! empty ($ content)? $ content: $ _POST ['content_lp'];
Now it works for me too.
Thanks,
Note:
The icons book and chat no longer appears.
Comparative img.

#10

Updated by iban goenaga almost 4 years ago

  • File needToAssociateAForumToTheItemFirst.png added
  • File IconsAppear.png added

Hi.

For the icons no longer appearing, did you associate a forum to each item where you want the forum icon?

#11

Updated by Tomas Rodrigues almost 4 years ago

  • File ckick_img.jpg added
  • File sempermissao_img2.jpg added

HI
True.
Thanks a lot for the help.

#12

Updated by Tomas Rodrigues almost 4 years ago

  • File deleted (sempermissao_img2.jpg)
#13

Updated by Tomas Rodrigues almost 4 years ago

  • File deleted (ckick_img.jpg)
#14

Updated by Tomas Rodrigues almost 4 years ago

  • Status changed from Needs testing to Bug resolved

Hi.
Iban Goenaga.
Thanks a lot for the help.
I'm closing this ticket.
fixed bug with:
https://github.com/chamilo/chamilo-lms/pull/975
Grateful

#15

Updated by Tomas Rodrigues almost 4 years ago

  • File deleted (img_1.jpg)
#16

Updated by Tomas Rodrigues almost 4 years ago

  • File deleted (img_2.jpg)
#17

Updated by Tomas Rodrigues almost 4 years ago

  • File deleted (img_3.jpg)
#18

Updated by Tomas Rodrigues almost 4 years ago

  • File deleted (learnpath.class.jpg)
#19

Updated by Tomas Rodrigues almost 4 years ago

  • File deleted (needToAssociateAForumToTheItemFirst.png)
#20

Updated by Tomas Rodrigues almost 4 years ago

  • File deleted (comparative.jpg)
#21

Updated by Tomas Rodrigues almost 4 years ago

  • File deleted (IconsAppear.png)
#22

Updated by Tomas Rodrigues almost 4 years ago

  • % Done changed from 70 to 100

Also available in: Atom PDF