Project

General

Profile

Bug #8483

Problème authentification CAS

Added by David Guénard over 2 years ago. Updated over 2 years ago.

Status:
Bug resolved
Priority:
High
Assignee:
-
Category:
Installation / Migration
Target version:
Start date:
02/11/2016
Due date:
% Done:

0%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Suite à la mise à jour de la version 1.10.6 vers la version 1.11

Après l'authentification avec CAS j'ai l'écran suivant :

cet identifiant est déjà pris !

Voir pièce jointe...


Files

cas.JPG (35.4 KB) cas.JPG David Guénard, 02/11/2016 17:08

History

#1

Updated by Yannick Warnier over 2 years ago

  • Target version changed from 1.11.2 to 1.11.4
#2

Updated by David Guénard over 2 years ago

en 1.11.4 le problème est toujours présent :

Dans un premier temps j'ai modifié :

$tab_user_info = api_get_user_info($login);

par $tab_user_info = api_get_user_info_from_username($login);

car $login est l'username pas l'id_user.

Ceci solutionne le problème de création d'un utilisateur malgré qu'il existe...

MAis le plugin CAS ne fonctionne toujours pas, après il a un problème de redirection très lente vers la page d'accueil.

Ce souci est bloquant pour l'université de REIMS, et nous envisageons de passer rapidement sous moodle

#3

Updated by David Guénard over 2 years ago

  • Status changed from New to Bug resolved

Après modification du processus d'authentification via le CAS dans chamilo, j'ai trouvé une solution qui fonctionne.

Also available in: Atom PDF