Project

General

Profile

Bug #8470

1.11 issues

Added by Paul Wolstencroft over 3 years ago. Updated over 3 years ago.

Status:
Bug resolved
Priority:
Low
Assignee:
Category:
Plugins
Target version:
Start date:
23/10/2016
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Just putting 1.11 through it's paces. Could be a simple answers here but I can't find them.

  1. On the new editor interface its seems it is not possible to insert an image at 100% as in the old editor because the width must be a number. (OK, we can set this in HTML but not useful for trainers) Can we get the old editor back?
  2. On the payments plugin there is no drop down list of currencies appearing.

Advice or suggestions welcome.

That's our only issues so far so well done on a great job.


Files

no currency dropdown.jpg (143 KB) no currency dropdown.jpg No currency dropdown Paul Wolstencroft, 23/10/2016 19:22
editor layout.jpg (239 KB) editor layout.jpg Paul Wolstencroft, 24/10/2016 12:52

Associated revisions

Revision eb633119 (diff)
Added by Angel Fernando Quiroz Campos over 3 years ago

Add option to show image responsive on ckeditor plugin - refs #8470

History

#1

Updated by Yannick Warnier over 3 years ago

  • Priority changed from Normal to Low

Hi, are you seeing this on an upgraded portal (from 1.9 or 1.10) or on a fresh install?

Absolutely no chance of getting back to the old editor, but the only change from 1.10 is the visual appearance. The FCKEditory in version 1.9 was not HTML5-compatible and not Safari-compatible and it required largely more than 300 hours of work to upgrade, so no way back.
I'm sure it can be adapted though, but that's not going to go on any community fast-track given its minor impact.

#2

Updated by Paul Wolstencroft over 3 years ago

Thanks for fast response Yannick.

Fantastic job on 1.11 - I can see a lot of great work here.

  1. On editor issue I may be missing something here. Not a 'minor impact' if learning paths can't be made responsive easily. (See the jpg sent to me by the trainer.) Just wonder how I tell trainers to insert graphics into tool headers and learning paths (they have no HTML knowledge) so that things remain responsive for mobile viewing. They are used to setting images at 100% and/or adding a bit of padding to stop text touching images. Is there a quick work around? Sorry if this is a basic question. My tech person Charlotte ia away for a month and you know I'm not very technical!
  2. On the currency dropdown issue. This works fine in 1.10.8 but I have tried two clean installs of 1.11 and get no dropdown for currency. (If this is not set the whole plugin seems not to work!) The server uses Ubuntu 14.04. PHP 5.5.9. Tried in Firefox, Chrome, Safari and Edge.

Any suggestions welcome. Keep up the good work.

#3

Updated by Paul Wolstencroft over 3 years ago

Any answer on how to insert an image set to 100% (See jpg) please? My trainer is now saying that no courses will load correctly from 10.8 to 1.11.

This is becuase they he used header artwork for EVERY tool and EVERY learning path with images set to 100% so they would display perfectly on mobile devices. There are also images within learning paths set to 100% with different padding to line up with text/graphics. He has 63 courses with an average of 25 images set to 100% in each course. These all display at the ACTUAL size on 1.11. It would be impractical to have to change nearly 1600 images/layouts in order to upgrade. He also says that where padding was set around an image, this no longer works correctly so many layouts are wrecked.

This is all due to the fact that the 'updated' editor' shows a cutdown panel to insert imaages rather than the 'standard' panel you might expect. Maages cannot be set to 100% and padding cannot be controlled. In other words you have actually REMOVED several useful features from Chamilo. The impct of the change is not just a 'visual appearance' as you suggest. It looks as though it may prevent many users from upgrading.

Appreciate all the work on this but do not understand why it cannot use the standard editor as shown on their latest demo and available in various CMSs - http://ckeditor.com/demo

I though this might be our set up but it's the same at https://1.11.chamilo.org so presume this is what you intended. Any help appreciated -traineer pulling hair out!


Only other issue is currency drop down so will open that as a separate issue.
Fantastic job otherwise. All seems OK except for Create Course link appearing for users (reported elsewhere)

#4

Updated by Julio Montoya over 3 years ago

  • Status changed from New to Assigned

I checked this issue and this is a matter of the chamilo template not about the image and ckeditor.

In 1.10 the iframe is located like this:

https://1.10.chamilo.org/main/document/showinframes.php?cidReq=TESTCOURSE&id_session=0&gidReq=0&gradebook=0&origin=&id=4329


<div id = page-wrap>
   <div id = top_main_content>
        <div class = "row">
           <div class = "col-md-12">
             <iframe>   

In 1.11 is:

https://1.11.chamilo.org/main/document/showinframes.php?cidReq=TEST123&id_session=0&gidReq=0&gradebook=0&origin=&id=249


<div id = page-wrap>
   <section id="content-section">
           <div class = "container">
             <iframe>   

So this change modifies the "responsive image effect" when resizing the browser.

#5

Updated by Julio Montoya over 3 years ago

  • Status changed from Assigned to Needs more info
  • Assignee set to Yannick Warnier

Yannick, I think that Alex made some changes about this? I don't remember changing that.

#6

Updated by Paul Wolstencroft over 3 years ago

Thanks Julio. The issue is not so much with templates but when inserting a graphic as a full width header for all tools and learning paths. Cannot see a way of setting this artwork to 100% or adding the padding required.

I guess the question is really why there is now an image insertion box with less features than before? Help appreciated as we can't switch to 1.11 with 63 courses that don't appear correctly.

If we are stuck with it I can get our guys to start reformatting courses but it's going to take weeks so hoping there is a fix. Thanks.

#7

Updated by Julio Montoya over 3 years ago

  • Status changed from Needs more info to Assigned
  • Assignee changed from Yannick Warnier to Angel Quiroz

hspace, vspace and border (the attributes missing in 1.11.x ) are not html5 supported:

http://www.w3schools.com/tags/tag_img.asp

I just checked and ckeditor doesn't allow percentage when inserting image.
See:

https://www.drupal.org/node/1909648

Apparently this change should fix it:

https://github.com/chamilo/chamilo-lms/commit/eb63311995407d3ded57c046e77153c9dc70b5f9

I will assign the task to AngelFQC.

When entering width "100%" I still have the message "Width must be a number.".

#9

Updated by Paul Wolstencroft over 3 years ago

Thanks Julio,

Tried Angel's fix but still got "Width must be a number". Followed your links and did some experimenting with the plugin but still can't get the image editor they show on their demo as the 'standard' editor. The one that appears in 1.11 seems so be a very old version (the one the threads you found refer to). See clip of CK standard demo: https://youtu.be/qc2JJFxPNIs

#10

Updated by Yannick Warnier over 3 years ago

This is fixed by Angel's fix but it probably requires a set of steps that are complex to have the new feature. With Angel's changes, there is a "Responsive" checkbox which adds the "img-responsive" CSS class to the img tag and ensures it is responsive (when the box is checked, dimensions are automatically voided).

We will release 1.11.2 today or tomorrow, so not a long time to wait (you can already test it on https://1.11.chamilo.org doing CTRL+F5 when looking at the editor).

#11

Updated by Paul Wolstencroft over 3 years ago

You guys are fantastic! Just realised that the tick box was there when we tried the fix but did not spot it 'doh'! Good solution.

By the way, https://1.11.chamilo.org is reset with no registration so we can't login to check it there but no problem as it works on our development platform.

Congratulations on getting 11.2 out so quickly.

#12

Updated by Yannick Warnier over 3 years ago

  • Category set to Plugins
  • Status changed from Assigned to Bug resolved
  • Target version set to 1.11.2
  • % Done changed from 0 to 100

1.11.chamilo.org can always be accessed with admin/admin ;-)
Closing this one then.

Also available in: Atom PDF