Project

General

Profile

Bug #8403

Assignments tool upload broken + AJAX table refresh bug

Added by Yannick Warnier almost 5 years ago. Updated almost 5 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
Category:
Assignments / Work
Target version:
Start date:
17/08/2016
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

  • enter as admin
  • create a course
  • create a task (with a score but no date - all other options default)
  • subscribe a student to the course
  • enter as a student
  • enter the assignments tool
  • the table of assignments appear but a small modal box appears on top saying "undefined" (my portal is in french) (see screenshot - that's the AJAX bug)
  • click the name of the task
  • click "upload assignment"
  • click on the bug upload area: nothing happens (bug n°2)
  • a green button "AddFiles" (not translated, bug 3) appears but it shouldn't be there (bug 4)
  • when clicking the green "AddFiles" button, a file selector appears but if I select a file to upload, nothing happens (bug 5)
  • during all that time, a small "*" character appears at the bottom left of the page (see screenshot)

Uploading through the "classic" upload feature works perfectly.

AJAX issue screenshot:

Upload task issue screenshot:


Files

tarea-undefined.png (6.17 KB) tarea-undefined.png Yannick Warnier, 17/08/2016 02:44
task.png (41.8 KB) task.png Yannick Warnier, 17/08/2016 02:44

History

#1

Updated by Julio Montoya almost 5 years ago

  • Assignee changed from Julio Montoya to Yannick Warnier

the table of assignments appear but a small modal box appears on top saying "undefined" (my portal is in french) (see screenshot - that's the AJAX bug)

I couldn't reproduce that error.

click on the bug upload area: nothing happens (bug n°2)
a green button "AddFiles" (not translated, bug 3) appears but it shouldn't be there (bug 4)

Fixed.

during all that time, a small "*" character appears at the bottom left of the page (see screenshot)

Fixed

#2

Updated by Yannick Warnier almost 5 years ago

  • Status changed from Assigned to Bug resolved
  • Assignee changed from Yannick Warnier to Julio Montoya
  • % Done changed from 0 to 100

Julio Montoya wrote:

the table of assignments appear but a small modal box appears on top saying "undefined" (my portal is in french) (see screenshot - that's the AJAX bug)

I couldn't reproduce that error.

Me neither. I'll watch for that in case I can see it again.

click on the bug upload area: nothing happens (bug n°2)
a green button "AddFiles" (not translated, bug 3) appears but it shouldn't be there (bug 4)

Fixed.

during all that time, a small "*" character appears at the bottom left of the page (see screenshot)

Fixed

Tested and approved.

Also available in: Atom PDF