Project

General

Profile

Bug #8190

Setting Registration Page

Added by Paul Wolstencroft about 6 years ago. Updated about 6 years ago.

Status:
Rejected - Abandoned
Priority:
Low
Assignee:
Paul Wolstencroft
Category:
Administration
Target version:
Start date:
08/04/2016
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Using 1.10.4 we set some information on the registration page when it was set to 'After Approval'. This was fine and we could re-visit the page to change the copy.

We then changed back to No Approval and could not access the registartion page setting no matter what registration setiing status is used. The error we get is:

QuickForm Error: nonexistent html elementQuickForm Error: nonexistent html element Tried on clean test patform and got same error.

Remeber this from a few years back but can't recall the fix.


Files

regpage.jpg (26.2 KB) regpage.jpg Paul Wolstencroft, 12/04/2016 10:55
Selection_002.png (31.7 KB) Selection_002.png Julio Montoya, 02/05/2016 15:08

History

#1

Updated by Yannick Warnier about 6 years ago

I think the error is a NOTICE level, right? We do not support NOTICE-level, so you have to change your PHP configuration to include "& ~E_NOTICE" in the error_reporting setting (and restart PHP/Apache).
If this is not a NOTICE level, it is usually a message that only appears once (when the cache has not been generated) and it will disappear after that.

If none of the above, please give us more details about the error itself (a screenshot, maybe?) and your server configuration (PHP version, Linux distribution, etc) so we can try and help you.

#2

Updated by Paul Wolstencroft about 6 years ago

Apache settings are correct for errors on our server and cache clear. Message appears when trying to set the registration page not in the error reporting. Tried repeating the steps on a clean (test) platform and got the same result. Editing of the registration page is fine BUT if you switch registration type from 'needs approval' to 'no appraoval' the error message than appears and remains if you try to switch back. (Screenshot attached)

PS - Ohterwise 1.10.4 performing really well. - great job.

#3

Updated by Yannick Warnier about 6 years ago

  • Category set to Administration
  • Target version set to 1.10.6
#4

Updated by Julio Montoya about 6 years ago

I visited this page settings and change all the 3 settings

and then I went here:

main/admin/configure_inscription.php

And I got any error. Maybe this was already fixed. PLease check in https://unstable.chamilo.org/

#5

Updated by Paul Wolstencroft about 6 years ago

Hi Julio,

Strange - this seems to occur when done in a different order. If we do as you did and try all three settings BEFORE setting the text on the registration page there is no error. However, if we change the text main/admin/configure_inscription.php and THEN change registrtion method, when we go back to main/admin/configure_inscription.php we get the message: * QuickForm Error: nonexistent html elementQuickForm Error: nonexistent html element*

Charlotte - Consult.PW -

#6

Updated by Yannick Warnier about 6 years ago

  • Status changed from Needs more info to Assigned
  • Assignee set to Julio Montoya
#7

Updated by Julio Montoya about 6 years ago

  • Status changed from Assigned to Needs more info
  • Assignee deleted (Julio Montoya)

Please, try to reproduce the error here, I cannot reproduce it.

https://1.10.chamilo.org/index.php (login/pass: admin/admin)

#8

Updated by Yannick Warnier about 6 years ago

  • Status changed from Needs more info to Needs testing
  • % Done changed from 0 to 80

Paul/Charlotte,

We will consider this issue solved if there's no additional feedback within 24h. Thank you for reporting.

#9

Updated by Paul Wolstencroft about 6 years ago

I just had another go on a fresh install and the same thing happened. Only happens if you do this in the order we tried before. i.e. Registration is set to 'needs approval' and we add text at main/admin/configure_inscription.php. This appears OK. If we than change the registration process to no approval needed we can no longer edit the registration page.

If no others have this issue then you should forget it and we'll let you know how it goes on 1.10.6 with a clean install. Did a double check on our server/PHP settings and with try on another one too.

STOP PRESS: Just had a thought as I was typing. We were using a sub language. Went back to the default English and it now works! OK, so tried more and the fault occurs when you use a sub language. I hope this helps.

Thank you for looking at it - Charlotte

#10

Updated by Yannick Warnier about 6 years ago

  • Status changed from Needs testing to Assigned
  • Assignee set to José Loguercio
#11

Updated by José Loguercio about 6 years ago

Hi, i do the following steps and still cant reproduce the error :

1. Swap a sublanguage (spanish sublanguage)
2. set to needs approval
3. edit the inscription page
4. set to No approval
5. re-edit the inscription page.

can you post here another relevant option about your portal to trying to reproduce the error?

Thanks :)

#12

Updated by José Loguercio about 6 years ago

  • Assignee changed from José Loguercio to Paul Wolstencroft
#13

Updated by Paul Wolstencroft about 6 years ago

Thanks José,

I tried a two other sub languages and can't reproduce the error with them. Since it's only with the English sub domain I created (and this is quite extensive)I suggest thet you close this one for now. When we do a clean 1.10.6 install, we will check after each word change to see if we can track down what makes it happen and report it if we can isolate the problem.

Charlotte

#14

Updated by Yannick Warnier about 6 years ago

  • Status changed from Assigned to Rejected - Abandoned
  • % Done changed from 80 to 100

Closing because of impossibility to reproduce in another environment. Thank you for reporting.

Also available in: Atom PDF