Project

General

Profile

Bug #8072

Platform admin cannot enter users list of a course he didn't create

Added by Yannick Warnier almost 4 years ago. Updated almost 4 years ago.

Status:
Rejected - Abandoned
Priority:
Normal
Category:
Administration
Target version:
Start date:
27/01/2016
Due date:
% Done:

0%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

  • Create a course
  • Edit the course (from the admin courses list)
  • Assign another teacher to the course and remove yourself (admin)
  • Save
  • Enter the course
  • Go to the users tool
  • Error

The admin should always be authorized to do anything in a course. I suspect the api_is_allowed_to_edit() is not taking api_is_platform_admin() into consideration for some weird permissions reason.

Check master too.

History

#1

Updated by Julio Montoya almost 4 years ago

  • Status changed from Assigned to Needs more info
  • Assignee changed from Julio Montoya to Yannick Warnier

It works for me. I tried it here:

https://unstable.chamilo.org/main/admin/course_list.php?keyword=julito&submit=&_qf__search_simple=

Course "Julito" the admin can enter with out problems. I changed also the course visibility.

Can you provide an example?

#2

Updated by Yannick Warnier almost 4 years ago

  • Status changed from Needs more info to Rejected - Abandoned

I always get the ghost-type bugs... :-/
Sorry. Cannot reproduce anymore.

Also available in: Atom PDF