Project

General

Profile

Bug #8049

Document folder. Do not unpack zip files.

Added by Tomas Rodrigues almost 4 years ago. Updated almost 4 years ago.

Status:
Bug resolved
Priority:
Normal
Category:
Documents
Target version:
Start date:
13/01/2016
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Hello.
When trying to send a document via click.
Does not work. Only the way drag and drop.
Now send the zip file mode.
And ask to unpack and save.
He says it will successfully saved.
When checking the folder you have nothing.

Associated revisions

Revision 432b5647 (diff)
Added by José Loguercio almost 4 years ago

Fix Drag & drop multiUpload Click Event in Chrome Browser - Refs #8049

Revision 6b279ef0
Added by Yannick Warnier almost 4 years ago

Merge pull request #991 from jloguercio/8045

Fix Drag & drop multiUpload Click Event in Chrome Browser - Refs #8049

Revision 3ba2835c (diff)
Added by José Loguercio almost 4 years ago

Fix Drag & drop multiUpload Click Event in Chrome Browser (master) - Refs #8049

Revision b8368766
Added by Yannick Warnier almost 4 years ago

Merge pull request #994 from jloguercio/patch-1

Fix Drag & drop multiUpload Click Event in Chrome Browser (master) - Refs #8049

History

#1

Updated by Tomas Rodrigues almost 4 years ago

new information
The problem of click and do not open.
Does not occur in Firefox, Microsoft Edge.

#2

Updated by Tomas Rodrigues almost 4 years ago

Hi.
Some more information.
Chamilo 1.10.2 installed in localhost for testing.
In localhost also not unpack.
using:
wampserver.

#3

Updated by José Loguercio almost 4 years ago

  • Status changed from New to Needs testing
  • Assignee set to Yannick Warnier
  • % Done changed from 0 to 90

PR : https://github.com/chamilo/chamilo-lms/pull/991/files

This fix the Drag & drop UI Click event to select a file in Chrome Browser, for the unpack zip file ... i can't reproduce the error it self, maybe its a permission problem, check your file and folder permission in "http://YOURCHAMILOINSTALATTION/app/courses/YOURCOURSENAME"

#4

Updated by Tomas Rodrigues almost 4 years ago

Hello.
I made the change. Now this ok.
Check the permissions of the folder on the server.
app = 0755
courses = 0755
nomedocurso = 0755
In fact all the folders are in 0755.
only .htaccess and Appkernel.php.
Are 0644.
Any idea?

#5

Updated by Yannick Warnier almost 4 years ago

Permissions are 755 for folders (they allow execution, which under Linux means the corresponding user can enter the directory and make a list of the files there) and 0644 for files (which means the owner can modify it but other users can only read/view it).
This is all OK, as far as I can see.

I'm waiting for our designer's approval to include the Pull Request proposed by José.

#6

Updated by José Loguercio almost 4 years ago

Can you attach your zip file anyway?, Thanks

#7

Updated by Tomas Rodrigues almost 4 years ago

Hello.
I can set everything up.
But when you click send.
He says he did everything successfully.
Only it did not.
Tested the package downloaded and installed on localhost.
Same problem.

#8

Updated by José Loguercio almost 4 years ago

Hello, if you can, attach your zip file here, to check it maybe your zip file is corrupted or something.

Thanks

#9

Updated by Tomas Rodrigues almost 4 years ago

Hi.
I tested the files before sending.
Created other files in zip format.
Using winrar and windows zip.
Grateful

#10

Updated by Yannick Warnier almost 4 years ago

  • Status changed from Needs testing to Bug resolved
  • Assignee changed from Yannick Warnier to José Loguercio
  • % Done changed from 90 to 100

Too little detail here. Cannot reproduce anymore. Not sure if this is completely fixed, but it looks like it. Closing.

#11

Updated by Tomas Rodrigues almost 4 years ago

  • File deleted (01.jpg)
#12

Updated by Tomas Rodrigues almost 4 years ago

  • File deleted (02.jpg)
#13

Updated by Tomas Rodrigues almost 4 years ago

  • File deleted (03.jpg)

Also available in: Atom PDF