Project

General

Profile

Bug #8010

1.9.2.10.x et 1.10 - export / import ne fonctionne plus

Added by Eric Petitdemange over 4 years ago. Updated about 4 years ago.

Status:
Bug resolved
Priority:
Normal
Category:
Backup
Target version:
Start date:
18/12/2015
Due date:
% Done:

50%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Bonsoir,

Ayant une démo de Chamilo début de semaine prochaine, je voulais faire un import/export, idéalement de 1.9.x => 1.10.
L'import ne fonctionnant pas sur 1.10, je me suis alors proposé de préparer la démo Export/import d'un cours de 1.9.10.x sur la même plate-forme mais dans un nouveau cours...
Surprise, l'export semble se faire, mais lors de l'import le message "aucun document trouvé" s'affiche et donc le parcours ne fonctionne pas.

J'ai testé dans tous les sens, même avec une archine en 1.9.1 (oui je sais ce n'est pas récent).... L'export/import ne fonctionne pas sous 1.10 et plus sous 1.9.10.x (x étant Github the latest)...

Bon courage....


Related issues

Related to Chamilo LMS - Bug #8113: Impossible d’importer un cours créé il y a 8 ans de la version 1.9.10 vers 1.10X du 1 mars 2016.Bug resolved01/03/2016

Actions

History

#1

Updated by Yannick Warnier over 4 years ago

  • Target version set to 1.10.4
#2

Updated by Yannick Warnier over 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Yannick Warnier
#3

Updated by Yannick Warnier over 4 years ago

  • Status changed from Assigned to New
  • Assignee deleted (Yannick Warnier)
  • Target version changed from 1.10.4 to 1.11.0

Je vais discrètement passer ceci à 1.11.x parce que, malheureusement, il ne s'agit pas pour nous d'une priorité communautaire (par rapport au travail titanesque requis). Sorry.

#4

Updated by Eric Petitdemange over 4 years ago

Pas de souci je joue juste mon rôle autoproclamé de testeur.
Mon objectif est de faire part de mes observations et d'essayer de les rendre reproductibles pour que vous puissiez avoir une bonne base de résolution ;)

J'avais prévu une démo à l'Université dans le cadre de mon Master 2. Le système D est toujours un sérieux allié ;)

Merci à toute l'équipe pour le travail !

#5

Updated by Yannick Warnier about 4 years ago

  • Category set to Backup
  • Status changed from New to Assigned
  • Assignee set to Julio Montoya

Ce problème devrait être corrigé pour la 1.11.

#6

Updated by Yannick Warnier about 4 years ago

  • Status changed from Assigned to Needs testing
  • Assignee changed from Julio Montoya to Eric Petitdemange

Eric, si tu as l'occasion de tester sur 1.11.chamilo.org, ça nous permettrait (peut-être) de clôturer cette tâche :-)

#7

Updated by Eric Petitdemange about 4 years ago

ça marche à 50%, en fait il faut passer en vue prof, puis apprenant puis à nouveau prof puis apprenant pour que celà fonctione, mais au moins on arrive à suivre le parcours ;)
On va dire OK pour clôturer, car au moins l'arborescence est conservée ;)

Bravo à vous ... Vivement une 1.11 en mode installation que je puisse faire des tests en local !
A+

#8

Updated by Yannick Warnier about 4 years ago

  • Status changed from Needs testing to Bug resolved
  • % Done changed from 0 to 50

Eric, si tu dois passer de prof à apprenant, il est possible que ce soit un problème de permissions. Pourrais-tu vérifier si tous les documents sont visibles dans l'outil documents?

Je ferme la tâche en attendant, mais j'espère taper juste sur le coup/clou des permissions.

#9

Updated by Eric Petitdemange about 4 years ago

Hello Yannick,
Non c'est un souci récurrent qui existe depuis la 9.0.
Par défaut lorsque tu es admin d'un cours, tu es en mode prof, donc tu vois l'arborescence des doc quand tu accèdes au cours.
Tu clique sur apprenant, tu vois toujours l'arbo, comme si la plate-forme te laissait en mode prof. tu reviens en vue prof, puis à nouveau vue étudiant et là soit tu as un contenu vide (ce qui se passait pour ce bug), soit tu as le cours qui marche.

Ce qui est "drôle", c'est qu'une fois que tu as fait ce passage multiple de vue, il arrive que cela fonctionne normalement le coup suivant (cache ou non ??)
Pour ce qui est des permissions j'ai monté une plate-forme sur un linux histoire de forcer un peu les choses, avec un chmod -R 777 à partir de la racine chamilo (évidemment pas en prod ni sur le net :) )
J'étais en full local sur mon PC, avec en plus un terminal en sudo, au cas où.... !
Une fois que tu connais le multi-clic vue apprenant / vue prof, tu fais les tests à fond....

#10

Updated by Yannick Warnier about 4 years ago

Ah oui, OK, j'ai compris. Oui, en général nous recommandons de faire les tests (pour les parcours) comme apprenant réellement, et pas en "vue apprenant".

Also available in: Atom PDF