Project

General

Profile

Bug #7938

Téléchargement image - Quiz - Hotspot

Added by Alain Deschênes almost 4 years ago. Updated almost 4 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
Category:
Exercises
Target version:
Start date:
04/11/2015
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Impressionné par cette version ;-)

Il semble y avoir un problème pour télécharger l'image sur les questions "Hotspot" dans les Quiz (Exercices) de la version 1.10.

Testé sur unstable.chamilo.org et sur campus.chamilo.org via Firefox 41.0.2 et via IE 11 sur Windows 7 et 10.

Au plaisir,

Alain


Files

Image.gif (20.3 KB) Image.gif Alain Deschênes, 04/11/2015 03:08

History

#1

Updated by Yannick Warnier almost 4 years ago

En effet, la version 1.10.0 a cassé le hotspot. Une autre tâche a été créée (en anglais ou espagnol, je ne sais plus) pour régler le problème et nous avons un des fournisseurs officiels qui travaille dessus pour le résoudre dans une version 1.10.2 qui corrigera, en même temps, de sérieux problèmes de mise à jour détectés de 1.9 à 1.10.

#2

Updated by Yannick Warnier almost 4 years ago

  • Category set to Exercises
  • Status changed from New to Rejected - Abandoned
  • Assignee set to Yannick Warnier
  • Target version set to 1.10.2
  • % Done changed from 0 to 100

Ceci devrait être réglé sur https://unstable.chamilo.org (créer un nouvel exercice et une nouvelle question).

Nous travaillons actuellement sur la migration de ce type de questions depuis la version 1.9, parce qu'il semble que les coordonnées soient stockées de façon légèrement différente, mais sinon ça fonctionne bien avec de nouvelles questions et sans Flash.

#3

Updated by Alain Deschênes almost 4 years ago

Salut Yannick,

J'ai testé le tout sur unstable.chamilo.org.

Effectivement, ça fonctionne, mais si on pousse l'investigation un peu plus loin...

Scénario 1
On revient en arrière dans un quiz à plusieurs questions, on ne voit plus les sélections faites sur l'image.
Cependant, le résultat correspond parfaitement à la sélection initiale.

Scénario 2
Idem au scénario précédent sauf que l'objectif ici est de modifier la sélection des zones sur image.
Cette fois, on refait une sélection, bien que cette dernière s'ajoute à la base de données, seule la première sélection est prise en compte.

On remarque le même phénomène sur le type de question "Correspondances glisser-déplacer"...

Le tout a été testé sur le cours "Test Parcours"
https://unstable.chamilo.org/main/exercice/overview.php?cidReq=TESTPARCOURS&id_session=0&gidReq=0&gradebook=0&origin=&exerciseId=4&preview=1

Toujours disponible pour tester,

Alain

#4

Updated by Yannick Warnier almost 4 years ago

  • Status changed from Rejected - Abandoned to Assigned
  • Assignee changed from Yannick Warnier to Angel Quiroz
  • % Done changed from 100 to 80

Bien vu. On va essayer de régler ça pour la 1.10.2

#5

Updated by Yannick Warnier almost 4 years ago

  • Status changed from Assigned to Bug resolved
  • % Done changed from 80 to 100

Voilà, c'est réglé dans la 1.10.2. Reste la question de type ordonner des mots qui ne se montre pas comme on l'avait laissée, mais cela fait l'objet d'une tâche pour la version suivante.

Also available in: Atom PDF