Project

General

Profile

Bug #7894

SCORM export is broken

Added by Yannick Warnier almost 4 years ago. Updated almost 4 years ago.

Status:
Rejected - Abandoned
Priority:
High
Category:
Learning paths / Lecciones
Target version:
Start date:
13/10/2015
Due date:
% Done:

0%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

When exporting and importing a chamilo learning path made with HTML documents from the course, the documents are replaced by a message saying the document could not be found.


Files

sdcdsc.zip (27.6 KB) sdcdsc.zip Yannick Warnier, 14/10/2015 02:50
lpex.png (70.9 KB) lpex.png Yannick Warnier, 14/10/2015 02:50
lpex2-ok-missing-docs.png (30.1 KB) lpex2-ok-missing-docs.png Yannick Warnier, 14/10/2015 02:50

History

#1

Updated by Julio Montoya almost 4 years ago

I works for me. Can you provide a zip to test what could be wrong?

#2

Updated by Julio Montoya almost 4 years ago

  • Status changed from Assigned to Needs more info
  • Assignee changed from Julio Montoya to Yannick Warnier
#3

Updated by Nicolas Ducoulombier almost 4 years ago

I can not reproduce this bug neither.

#4

Updated by Yannick Warnier almost 4 years ago

In my case when I export and try to re-import as SCORM, I get: "Unknown package format"
Attaching the zip and a screenshot (lpex.png) to get an idea of how it should look in the end (although I suspect the HotPotatoes test might not appear or appear as a document, but that's not a big issue for the SCORM export).

I was in test server mode. Maybe that has some kind of impact, so I did it in production mode as well. In production mode, I'm able to re-import the zip (it understands it's a SCORM) but the HTML documents are missing (see lpex2-ok-missing-docs.png), as when Alex reported it the first time.

Also worth noting: the HTML document (repeated twice in the LP) is actually a blank document. It only contains an empty <head> and an empty <body>, but in Alex's case, it contained text and images.

#5

Updated by Julio Montoya almost 4 years ago

  • Status changed from Assigned to Needs more info
  • Assignee changed from Julio Montoya to Yannick Warnier

Yannick Warnier wrote:

In my case when I export and try to re-import as SCORM, I get: "Unknown package format"
Attaching the zip and a screenshot (lpex.png) to get an idea of how it should look in the end (although I suspect the HotPotatoes test might not appear or appear as a document, but that's not a big issue for the SCORM export).

I cannot open that zip file in my file system. So Chamilo sends a correct message.

I was in test server mode. Maybe that has some kind of impact, so I did it in production mode as well. In production mode, I'm able to re-import the zip (it understands it's a SCORM) but the HTML documents are missing (see lpex2-ok-missing-docs.png), as when Alex reported it the first time.

Also worth noting: the HTML document (repeated twice in the LP) is actually a blank document. It only contains an empty <head> and an empty <body>, but in Alex's case, it contained text and images.

I tried here:

https://unstable.chamilo.org/main/newscorm/lp_controller.php?action=list&isStudentView=false&cidReq=TESTJULIO1&id_session=0&gidReq=0&gradebook=0&origin=

LP named "test 1".
I did an export and then an import in my local platform, and it works.
The only issue here is the image in the last step is not imported.

#6

Updated by Yannick Warnier almost 4 years ago

  • Status changed from Needs more info to Rejected - Abandoned

Looks like the problem might have been on my side: the latest patch for documents uploading actually put the document elsewhere than what was shown in the database. Closing. Sorry about that.

Also available in: Atom PDF