Project

General

Profile

Bug #7886

Backup | Copy Course

Added by AliaMori com almost 4 years ago. Updated almost 4 years ago.

Status:
Bug resolved
Priority:
Urgent
Assignee:
Category:
Backup
Target version:
Start date:
08/10/2015
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

When, in unstable.chamilo.org I attempt to copy a I receive a fatal error. Error image is attached.

This fatal error is the same for both "full copy" and for "Let me select learning objects".


Files

fatal error.pdf (131 KB) fatal error.pdf AliaMori com, 08/10/2015 08:25
docs-sel.png (63.8 KB) docs-sel.png Yannick Warnier, 14/10/2015 02:40
docs-res.png (30.9 KB) docs-res.png Yannick Warnier, 14/10/2015 02:40
1-aaa-20151013-193808.zip (1.45 MB) 1-aaa-20151013-193808.zip Yannick Warnier, 14/10/2015 02:42
import backup fatal error.png (195 KB) import backup fatal error.png Fatal error when importing a backup AliaMori com, 14/10/2015 03:04
full copy backup.png (128 KB) full copy backup.png Fatal error when attempting a full copy backup AliaMori com, 14/10/2015 03:04
import course.png (261 KB) import course.png AliaMori com, 15/10/2015 10:55
copy course.png (20.4 KB) copy course.png AliaMori com, 15/10/2015 10:55
error.png (80 KB) error.png Nicolas Ducoulombier, 15/10/2015 12:07
My Organisation - My campus - test import - Import backup 2015-10-15 12-02-36.png (84.5 KB) My Organisation - My campus - test import - Import backup 2015-10-15 12-02-36.png Nicolas Ducoulombier, 15/10/2015 12:07
1_ENGLISHFORBEGINNERS_20151015-114356.zip (7.44 MB) 1_ENGLISHFORBEGINNERS_20151015-114356.zip Nicolas Ducoulombier, 15/10/2015 12:07

Associated revisions

Revision eac3a26c (diff)
Added by Julio almost 4 years ago

Fix fatal error see #7886

Revision 8b099b4f (diff)
Added by Julio almost 4 years ago

Fix course document import see #7886

Revision 3aeead0e (diff)
Added by Julio almost 4 years ago

Fix queries + adding intval see #7886

Revision 66532e06 (diff)
Added by Julio almost 4 years ago

Fix fatal error see #7886

History

#1

Updated by Yannick Warnier almost 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Julio Montoya
  • Priority changed from Normal to High

This one is for Julio (complex stuff)

#2

Updated by Julio Montoya almost 4 years ago

  • Status changed from Assigned to Needs testing
  • Assignee deleted (Julio Montoya)

Should be fixed now.

#3

Updated by Yannick Warnier almost 4 years ago

This still doesn't work as it should. I'm selecting 2 documents and 2 images (see first screenshot) and as a result, in the zip file I only have 2 images, and the documents folder is empty.

I believe many things in the backup might be failing because of the changes in table IDs, and Julio, you are the one that knows better about all these changes, so please make sure you check everything thoroughly.

#4

Updated by Yannick Warnier almost 4 years ago

  • Status changed from Needs testing to Assigned
  • Assignee set to Julio Montoya
  • Priority changed from High to Urgent
  • % Done changed from 0 to 10

The official release is tomorrow, so I'm elevating the priority to "urgent".

#6

Updated by AliaMori com almost 4 years ago

I tested on unstable.chamilo.org:

1. Partial copy seems to be fixed. Thank you.

2. Full copy returned a fatal error (image attached). I used the "empty this course" tool and tried again: Partial copy is working but full copy is giving a fatal error.

3. As per Backup function: Both the complete and the partial ("select learning objects") functions are working for me.

5. Import Backup: When importing "full backup" or partial backup from "local file" I receive a fatal error. Image attached.

#7

Updated by Julio Montoya almost 4 years ago

  • Status changed from Assigned to Needs testing

I fixed the error when importing this file 1-aaa-20151013-193808.zip

I also fixed that fatal error.

#8

Updated by Julio Montoya almost 4 years ago

  • Assignee deleted (Julio Montoya)
#9

Updated by Yannick Warnier almost 4 years ago

I won't be able to test thoroughly this morning. Counting on you guys in Europe to test different scenarios!

#10

Updated by AliaMori com almost 4 years ago

I don't know about the guyz in Europe, but us guys and gals here in the far reaches of North-Eastern Asia were able to test some scenarios. Tested on unstable.chamilo.org. Here goes:

1. Partial copy - Yes, fully functional.

2. Full copy . - Great, now fully functional.
__
3. As per *Backup
function: - Yep, fully functioning.

4. Import Backup: - Superb. Fully functioning.

5. Empty Course (both partial/full): Fully working.
SUGGESTION:
"Copy" course and "Import Backup" functions return a listing of all the files / paths copied or imported. For the amateur, this might cause confusion and fear (see attached images). I suggest to relocate the "copy is finished" / "import is finished" message to the top of the page (versus bottom of page).

#11

Updated by Julio Montoya almost 4 years ago

AliaMori com wrote:

SUGGESTION:* "Copy" course and "Import Backup" functions return a listing of all the files / paths copied or imported. For the amateur, this might cause confusion and fear (see attached images). I suggest to relocate the "copy is finished" / "import is finished" message to the top of the page (versus bottom of page).

I just remove those messages.

#12

Updated by AliaMori com almost 4 years ago

Don Julio: 100 mil gracias.

Sugiero cerrar esta ficha como "resuelta".

saludos.

#13

Updated by Nicolas Ducoulombier almost 4 years ago

Hi,

I was testing exporting from chamilo 1.9.x to chamilo 1.10
And it works well for full import of backup but if I choose to select files to import I get a fatal error:

first on the import page select "Let me select learning objects"
main/coursecopy/import_backup.php?cidReq=TESTIMPORT&id_session=0&gidReq=0&gradebook=0&origin=

I attach the course from chamilo1.9.x that I'm trying to import.

#14

Updated by Julio Montoya almost 4 years ago

Nicolas Ducoulombier wrote:

Hi,

I was testing exporting from chamilo 1.9.x to chamilo 1.10
And it works well for full import of backup but if I choose to select files to import I get a fatal error:

first on the import page select "Let me select learning objects"
main/coursecopy/import_backup.php?cidReq=TESTIMPORT&id_session=0&gidReq=0&gradebook=0&origin=

I attach the course from chamilo1.9.x that I'm trying to import.

Should be fixed now.

#15

Updated by Nicolas Ducoulombier almost 4 years ago

It's all good for me too.

#16

Updated by Yannick Warnier almost 4 years ago

  • Status changed from Needs testing to Bug resolved
  • % Done changed from 10 to 100

Based on the feedback and a few manual tests, I'm closing this issue. Thanks to everyone involved.

Also available in: Atom PDF