Project

General

Profile

Bug #7624

Edit admin user: expiration date changes to null

Added by Yannick Warnier over 4 years ago. Updated over 4 years ago.

Status:
Rejected - Abandoned
Priority:
Normal
Category:
Users/Groups
Target version:
Start date:
09/04/2015
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

When you edit an admin user and change any field, the expiration date changes to null, which prevents later connections.
This is probably caused by the fact that the expiration date field does not appear in the form for admins edition, so it is considered null. The issue is that it doesn't seem to allow the admin user to login again (so it's probably set to "0000-00-00 00:00" in fact).

History

#1

Updated by Yannick Warnier over 4 years ago

  • Assignee changed from Julio Montoya to Angel Quiroz
#2

Updated by Yannick Warnier over 4 years ago

  • Description updated (diff)
#3

Updated by Julio Montoya over 4 years ago

This was fixed in 1.10.x.doctrine

#4

Updated by Yannick Warnier over 4 years ago

  • Assignee changed from Angel Quiroz to Julio Montoya
  • Priority changed from Urgent to Normal

On a fresh 1.10.x install today (with the doctrine changes), when trying to edit my own user, I get an empty form. When changing the config to allow me to edit some fields, I get empty (editable) fields.

#5

Updated by Julio Montoya over 4 years ago

  • Assignee changed from Julio Montoya to Angel Quiroz

I did a fresh install here: (with doctrine changes)

https://unstable.chamilo.org

Editing the admin user here:

https://unstable.chamilo.org/main/admin/user_edit.php?user_id=1

works for me.

#6

Updated by Yannick Warnier over 4 years ago

  • Status changed from Assigned to Rejected - Abandoned
  • Assignee changed from Angel Quiroz to Yannick Warnier
  • % Done changed from 0 to 100

Works for me too. Thanks.

Also available in: Atom PDF