Project

General

Profile

Support #7606

Buy_courses plugin : user or session problem

Added by Fabien Malassingne over 4 years ago. Updated about 4 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
Category:
Plugins
Target version:
Start date:
01/04/2015
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Hi everybody out there,

I'm running a platform with Chamilo 1.9.10.
I've encountered a problem with the buy_courses plugin. It seems that there are many problems with that plugin (I've read about it in the support) and that they'll might be fixed for 1.10 . Thanks for that.

Anyway, the problem I encounter is a bit different, dunno if it's a bug ou a configuration error :

I've activated the plugin as it is told in the video tutorial from Yannick Warnier.

When I want to configure payments or whatever else (as in https://youtu.be/iLSC08x_gvc?t=6m25s ) , I get an error :

Désolé, vous n'êtes pas autorisé à accéder à cette page, ou votre connexion a expiré. Veuillez cliquez sur le bouton "Précédent" de votre navigateur ou suivre le lien ci-dessous pour retourner à la page précédente.
(Sorry, you're not allowed to access to this webpage, or your connection has expired. Please click on the "Previous" button of your browser or follow the link below to return to previous page :: Home page)

I'm logged as administrator. I've tried with 3 different administrator accounts, that doesn't change the problem.
For information, I can access http://xxx.xx/main/admin/configure_plugin.php?name=buycourses and http://xxx.xx/plugin/buycourses/src/list.php without any problem.

History

#1

Updated by Yannick Warnier over 4 years ago

  • Status changed from New to Needs testing
  • % Done changed from 0 to 90

Hi Fabien,

This is the same error I mentionned was fixed in 1.10. Alternatively, it has also been fixed in 1.9.x (git repo) in https://github.com/chamilo/chamilo-lms/commit/68ce8d755a6e5a7f4c7ed01e21d6bd87d5edeff6
(you might also check https://github.com/chamilo/chamilo-lms/commit/76e9ecaa796a69bface2a86ff2cbcfd582f5e554)

You can easily apply these fixes by hand, or if you're crazy enough (like us) to have it as a git repo, you can just git pull origin 1.9.x (if you're in the 1.9 branch)

#2

Updated by Fabien Malassingne over 4 years ago

Hi Yannick,

I've applied the fixes by hand, it seems to work ! :)

I still encounter a problem : a click on the button "Search [courses]" in the buy_course plugin won't send : the page stays still.

I think this is a problem due to a change I did, maybe I've done wrong things when applying changes by hand.

I'll wait for the 1.10 :)

#3

Updated by Yannick Warnier over 4 years ago

Ça ira plus vite en français: les cours n'apparaissent que s'ils respectent certaines propriétés:
  • qu'ils aient un coût
  • qu'ils soient configurés comme non-publics et non-fermés/cachés
#4

Updated by Yannick Warnier over 4 years ago

  • Target version set to 1.10.0
#5

Updated by Yannick Warnier about 4 years ago

  • Category set to Plugins
  • Status changed from Needs testing to Bug resolved
  • Assignee set to Imanol Losada
  • % Done changed from 90 to 100

No news from Fabien in 2 months, so I assume this is fixed.

#6

Updated by Fabien Malassingne about 4 years ago

Hi Yannick.

I have to say I thought the problem was due to a bad handling I did, so I didn't test it further.

I'm gonna try it out again on another server in a few days. Thanks for reminding me.

Also available in: Atom PDF