Project

General

Profile

Bug #7586

Learning path always have a warning: Learners cannot see this learning path

Added by ha nguyen over 4 years ago. Updated over 4 years ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
Learning paths / Lecciones
Target version:
Start date:
16/03/2015
Due date:
% Done:

0%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Hello,
I'm new here and want to submit a new bug that I believe in my case.
Steps to reproducible
1 - User 1: Create a open course (not a Public course)
2 - User 2 (admin): Create a learning part in that course. Then Public the course (see the attachment)
=> This Learning Path always warn: Learners cannot see this learning path


Files

Learning paths.png (19.9 KB) Learning paths.png ha nguyen, 16/03/2015 08:12

History

#1

Updated by Yannick Warnier over 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Imanol Losada
#2

Updated by Imanol Losada over 4 years ago

  • Status changed from Assigned to Needs more info
  • Assignee deleted (Imanol Losada)

Dear Ha Nguyen.

We followed your steps but we can't reproduce your error. It works fine for us.

Could you give us more information about your problem? What version of Chamilo are you using?

We will close this ticket if we do not receive any response from you in the next 5 days.

Best Regards

#3

Updated by Imanol Losada over 4 years ago

  • Status changed from Needs more info to Rejected - Abandoned
#4

Updated by ha nguyen over 4 years ago

Thank you for your support.
I am so sorry that I did not update this issue for a long time because I thought that you would not reply this issue.
After some days I posted this issue, I found out that it came from the Publication Date option when I created that learning path. This option always was checked but in some cases, the time was set later than the current time, so that the learning path could not view by user after we created.
I tested this issue today but did not reproduce it. Don't know why but I will post the case if it occur again.
My version is 1.9.10.

#5

Updated by ha nguyen over 4 years ago

Ok I know the reason. The time is used to set for this option is the time on server. In my case, server is in US but administrator are in Vietnam. I changed the time-zones setting in configuration settings and everything is fine now.
Maybe we should not set default value of Publication Data is true or we can warning about this time-zone case to administrators or we can have more information with the warning "Learners cannot see this learning path" such as by a tooltip.

#6

Updated by Yannick Warnier over 4 years ago

  • Status changed from Rejected - Abandoned to New
  • Target version deleted (1.10.0)

Great! Thank you for your feedback. We'll try to add a proper comment when we finish the migration to the new language system!

#7

Updated by Yannick Warnier over 4 years ago

  • Target version set to 1.10.0
#8

Updated by Yannick Warnier over 4 years ago

  • Priority changed from High to Low
  • Target version changed from 1.10.0 to 2.0

Also available in: Atom PDF