Project

General

Profile

Feature #7513

Remove track_c tables

Added by Yannick Warnier over 4 years ago. Updated over 4 years ago.

Status:
Rejected - Abandoned
Priority:
Normal
Category:
Database & API changes
Target version:
Start date:
05/02/2015
Due date:
% Done:

0%

Estimated time:
2.00 h
Complexity:
Normal
SCRUM pts - complexity:
8

Description

As far as I know, we don't use the track_c_* tables anymore (since at least 5 years).
They were initially used to analyse web traffic, but were very inefficient and tools like awstats (and now Piwik) demonstrated a much higher efficiency at doing the same thing.

This is why we should remove them (they confuse people as to why they are present).

Actions to be taken:
  • Check all references to these tables (make sure they are not used anymore)
  • Eliminate the code that uses them
  • Eliminate the tables (from db_stats.sql/db_main.sql and with a drop table in migrate-db)
  • Make sure all database constants that relate to these tables are removed as well

Just to be safe, I'm talking about track_c_browsers, track_c_countries, track_c_os, track_c_providers, and track_c_referers


Related issues

Related to Chamilo LMS - Feature #7597: Remove unused tables: track_c_countries, track_c_browsers, track_c_os, track_c_providers, track_c_referersFeature implemented30/03/2015

Actions

History

#1

Updated by Yannick Warnier over 4 years ago

  • Tracker changed from Bug to Feature
  • Description updated (diff)
#2

Updated by Julio Montoya over 4 years ago

+1

#3

Updated by Yannick Warnier over 4 years ago

  • Status changed from Assigned to Rejected - Abandoned

This is a duplicate of #7597, so I'm closing it here

Also available in: Atom PDF