Project

General

Profile

Bug #7511

Exercise review mode: missing a question

Added by Yannick Warnier over 4 years ago. Updated over 4 years ago.

Status:
Rejected - Abandoned
Priority:
Normal
Category:
Exercises
Target version:
Start date:
05/02/2015
Due date:
% Done:

0%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

  • Build a 10-questions test (in a 1.10.* git version)
  • Enable review mode (not random)
  • Take the test (as a teacher)
  • Mark question 2 for review
  • Leave questions 5 and 6 without answer
  • Answer all other questions
  • On the review screen, check q5 and q6 (q2 is already checked)
  • Click "review"
  • The system gives you q2 (uncheck the box), then q6 (uncheck the box), but not q5!
  • You land on the review page again (q5 is still checked)
  • Click "review"
  • The system gives you q5
  • The end

Obviously, the system should show q5 in the first review cycle.

History

#1

Updated by Julio Montoya over 4 years ago

  • Status changed from Assigned to Needs more info
  • Assignee changed from Julio Montoya to Yannick Warnier

I'm using this version:

commit c8a8ca516a9fe33d66b90d23611d348cc172c120
Author: Julio Montoya <gugli100@gmail.com>
Date:   Thu Feb 5 08:34:32 2015 +0100

    Fixing db_persistent_connection notice

I cannot reproduce the error, I tried several times and it works for me.

When I arrived to this step:

The system gives you q2 (uncheck the box), then q6 (uncheck the box), but not q5!

I have the 3 questions.

All my questions are "multiple choice" and "multiple answer".

Maybe you have a warning in the ajax request that is blocking something?

This error appears in 1.9x?

#2

Updated by Yannick Warnier over 4 years ago

  • Status changed from Needs more info to Rejected - Abandoned

Tested in 1.10.x and it works fine. Closing. Could not reproduce it myself.

Also available in: Atom PDF