Project

General

Profile

Bug #7503

Oogie and remote access to conversion service

Added by Alexander Hu over 7 years ago. Updated over 7 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Plugins
Target version:
-
Start date:
02/02/2015
Due date:
% Done:

0%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Hello everybody,

just noticed that if you don't set up your localhost as a conversion server, you won't get your powerpoint/impress files converted as a learning path.

I have just reviewed the code, and there seems to be a little fuzz :-)
(inserted fpt server/user/pass, no luck :-( )

Anybody interested to fix this?
Otherwise i think the remote functionality should be cut out due to security risk.


Files

oogie (1.34 KB) oogie Alexander Hu, 02/02/2015 18:31

History

#1

Updated by Yannick Warnier over 7 years ago

Hi Alex, I don't really get your report. What is the real issue here?
If you install Oogie on your localhost as indicated in the install doc, and enable the oogie extension, it should work.

If you want to use your server as a remote PPT conversion server, it works as well (although you are right that security must be increased -> is this your bug report?)

#2

Updated by Alexander Hu over 7 years ago

Hello Yannick,

yes, as a local service -> 0 problems.
Works as usual.
If you want, i can attach my LSBInit-Script here for running this as a service.

But i also tried to use a remote server -> no luck with that.
Did i miss something special about the setup?

I know that this worked in the past, so i was a bit irritated about the not working connection.

#3

Updated by Yannick Warnier over 7 years ago

  • Category set to Plugins

Not sure to what time "in the past" you are referring. We worked on that in the run-up to Chamilo 1.9.10, so now it's in 1.9.10 and it works fine.
To run it as a remote server, you have to have a complete installation of Chamilo with the converter working, then indicate the URL of that server to your remote installation that will use it.

Feel free to paste your LSB script for others (we have something working ourselves, but it is more of an internal config)

#4

Updated by Alexander Hu over 7 years ago

Okay, just did a fresh local install, using 1.9.10 instead of 1.9.8.2

After upload of the impress file, i get:

PHP Fatal error:  Uncaught SoapFault exception: [HTTP] Unable to parse URL in /var/www/chamilo/main/newscorm/openoffice_document.class.php:204\nStack trace:\n#0 [internal function]: SoapClient->__doRequest('<?xml version="...', 'xxx.xxx.xxx.xxx', 'xxx.xxx.xxx.xxx#w...', 1, 0)\n#1 /var/www/chamilo/main/newscorm/openoffice_document.class.php(204): SoapClient->__call('wsConvertPpt', Array)\n#2 /var/www/chamilo/main/newscorm/openoffice_document.class.php(135): OpenofficeDocument->_get_remote_ppt2lp_files(Array)\n#3 /var/www/chamilo/main/newscorm/lp_upload.php(94): OpenofficeDocument->convert_document(Array)\n#4 /var/www/chamilo/main/upload/upload_ppt.php(34): require_once('/var/www/chamil...')\n#5 {main}\n  thrown in /var/www/chamilo/main/newscorm/openoffice_document.class.php on line 204, referer: http://localhost/chamilo/main/upload/upload_ppt.php?cidReq=TEST&id_session=0&gidReq=0&origin=&curdirpath=/&tool=learnpath

xxx.xxx.xxx.xxx -> remote IP/hostname

Attached is the init script.

Also available in: Atom PDF