Project

General

Profile

Bug #7432

Invalid start and end time in exercise

Added by Torkil Zachariassen over 4 years ago. Updated over 4 years ago.

Status:
Rejected - Abandoned
Priority:
Normal
Assignee:
-
Category:
Exercises
Target version:
Start date:
28/11/2014
Due date:
% Done:

0%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

I have a problem with "Enable start/end time" in "Test management" ( main/exercice/exercise_admin.php ).

If the time is after 12:59 or less than 01:00 the answer is "The form contains incorrect or incomplete data. Please check your input."

One of attached files shows "2014-12-01 13:00" and "2014-12-02 00:59" as invalid times, while the other shows "2014-12-01 12:59" and "2014-12-02 01:01" as valid times. The difference is just minutes.

I need to use "19:00" as an ending time. This seems to be impossible.

Running chamilo-1.9.8.2 on CentOS 7


Files

dated_invalid.png (16.8 KB) dated_invalid.png Invalid times Torkil Zachariassen, 28/11/2014 21:03
dates_valid.png (15.1 KB) dates_valid.png Accepted times Torkil Zachariassen, 28/11/2014 21:03

History

#1

Updated by Tomas Rodrigues over 4 years ago

Olá,
Você escolheu a versão 1.9.10, esta errado. A versão do problema é 1.9.8.2 certo?
Eu Tinha este problema "parecido" na v1.9.8.2 Que foi Resolvido aqui: https://github.com/chamilo/chamilo-lms/commit/03a9f8bbaf93b43f2c31c4e541c3ad50a33d192f
Veja se ajuda.
att.
Marcelo Bassuma
ps: a versão 1.9.10 não terá mais este bug.

#2

Updated by Torkil Zachariassen over 4 years ago

Marcelo

Thank you very much for a quick answer.

Changing the 'h' to 'H' did the trick, and saved my day.

Pardon for selecting the wrong version, yes, this happend on 1.9.8.2 as indicated in the bug report.

This indeed seems to a duplicate of #7319, and can be closed.

#3

Updated by Yannick Warnier over 4 years ago

  • Status changed from New to Rejected - Abandoned

Duplicate of #7319. Thanks.

#4

Updated by Tomas Rodrigues over 4 years ago

Ok.
:)

Also available in: Atom PDF