Project

General

Profile

Bug #7351

Custom Documents link is unavailable for students when original icon is set to invisible

Added by Paweł Cisło almost 5 years ago. Updated about 4 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
Category:
Administration
Target version:
Start date:
25/10/2014
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

When I create a custom course home page (following the suggestion in Teacher's Manual) by making all the modules invisible to the students and creating my own page (in the intro section) with links to the selected modules, the Documents module isn't available to students - when they click the link, they get the message that they don't have access to that page. When I make Documents visible, the link works for them correctly. But of course the whole idea is to have the original icons invisible while assigning the link to an icon in the custom page. The other modules I've tried so far (Course Progress, Assignment, Links) work correctly, even if the visibiblity of the original icons is disabled.

Associated revisions

Revision def27d02 (diff)
Added by Julio Montoya about 4 years ago

Remove visibility condition see #7351

History

#1

Updated by Paweł Cisło almost 5 years ago

Chamilo 1.9.8

#2

Updated by Yannick Warnier almost 5 years ago

  • Assignee deleted (Julio Montoya)
#3

Updated by Yannick Warnier almost 5 years ago

  • Target version set to 1.10.0
#4

Updated by Yannick Warnier over 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Imanol Losada
#5

Updated by Yannick Warnier about 4 years ago

  • Assignee changed from Imanol Losada to Julio Montoya
#6

Updated by Julio Montoya about 4 years ago

  • Status changed from Assigned to Needs testing
  • Assignee deleted (Julio Montoya)
#7

Updated by Yannick Warnier about 4 years ago

  • Subject changed from Costom Documents link is unavailable for students when original icon is set to invisible to Custom Documents link is unavailable for students when original icon is set to invisible
#8

Updated by Yannick Warnier about 4 years ago

  • Status changed from Needs testing to Bug resolved
  • Assignee set to Julio Montoya
  • % Done changed from 0 to 100

This is fixed in 1.10.0 (we will not fix it on 1.9.10 ourselves as 1.10.0 is very close to being published) and can be tested on https://unstable.chamilo.org/

I personally tested it and it works now.

Also available in: Atom PDF