Project

General

Profile

Bug #7233

Accents et glossaire

Added by Anonymous about 5 years ago. Updated about 4 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
Category:
Glossary/Glosario
Target version:
Start date:
20/08/2014
Due date:
% Done:

100%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Lorsqu'on paramètre le glossaire pour un affichage automatique des définitions dans les exercices, la mise en surbrillance des mots ne se fait que pour les mots ne commençant pas ou ne finissant pas par un accent.
Exemple ici :
https://stable.chamilo.org/courses/TESTGLOSSAIRE/index.php

Dans le glossaire, il y a 3 "mots" avec des accents placés à divers endroits.
Quand on va sur l'exercice ces mots sont mis en surbrillance... ou pas, selon l'emplacement de l'accent...


Files

Selection_013.png (16.1 KB) Selection_013.png Julio Montoya, 02/07/2015 13:17

Related issues

Blocked by Chamilo LMS - Bug #7638: Glossary terms do not appear anymoreBug resolved18/04/2015

Actions

Associated revisions

Revision 19995bb7 (diff)
Added by Imanol Losada over 4 years ago

Correct glossary word boundary accents issue - refs #7233

History

#1

Updated by Yannick Warnier almost 5 years ago

  • Target version set to 1.10.0
#2

Updated by Yannick Warnier over 4 years ago

Translation for treatment in other languages:
In glossary, with automatic highlighting mode configured in the platform settings, when a word starts or ends with an accent, it isn't highlighted:
  • éclair: KO
  • fête: OK
  • mangé: KO
#3

Updated by Yannick Warnier over 4 years ago

  • Category set to Glossary/Glosario
  • Status changed from New to Assigned
  • Assignee set to Imanol Losada
#4

Updated by Imanol Losada over 4 years ago

  • Assignee changed from Imanol Losada to Yannick Warnier
  • % Done changed from 0 to 70
#5

Updated by Yannick Warnier over 4 years ago

I cannot see the effect of this patch at the moment, but I believe this is due to something else (that's why I created #7638). I cannot close this issue until I can test it, so #7638 will have to be closed first.

#6

Updated by Yannick Warnier over 4 years ago

  • Status changed from Assigned to Needs testing
#7

Updated by Julio Montoya about 4 years ago

It works for me in chamilo 1.10

It can be tested here: unstable.chamilo.org

#8

Updated by Yannick Warnier about 4 years ago

  • Status changed from Needs more info to Bug resolved
  • Assignee set to Imanol Losada
  • % Done changed from 70 to 100

Great. Thanks for the testing. Closing.

Also available in: Atom PDF