Project

General

Profile

Feature #6887

Remove css/frames.css from documents.

Added by Julio Montoya over 5 years ago. Updated about 4 years ago.

Status:
Feature implemented
Priority:
Normal
Assignee:
-
Category:
Documents
Target version:
Start date:
24/12/2013
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Any idea why we add this css "css/frames.css" in every new HTML document?


Related issues

Related to Chamilo LMS - Feature #6903: Move public folders (css/js/img) inside webFeature implemented31/12/2013

Actions

History

#1

Updated by Yannick Warnier over 5 years ago

Not sure, but I think it's to allow the exported document to still look good... I think there must be some similar task already (I think I already asked myself that same question in the past).

#2

Updated by Julio Montoya over 5 years ago

  • Status changed from New to Needs more info

I don't agree with that. All chamilo documents should be "clean" with out any css, if you want to add some CSS it should be added in the html file with the <style></style> tag.

#3

Updated by Yannick Warnier over 5 years ago

I don't agree with you not agreeing :-)
I think the problem is deeper than you think it is.
If you force the CSS to be inside the document itself, you are making it non-reusable.
If you ask for all the style from the HTML documents to be inside the basic Chamilo style, you are possibly injecting a lot of non-HTML5 CSS inside Chamilo.
If you export the documents to read them offline and you have replicated 500 lines of CSS in each one, you are replicating a lot of code.
Really, there is some merit on having a stylesheet for documents. The only thing is that we need to find a way to make it clear that this is only for documents. Something like a "print.css" but not for print. Maybe "static-html.css" or something like that.

#4

Updated by Julio Montoya over 5 years ago

Yannick Warnier wrote:

I don't agree with you not agreeing :-)
I think the problem is deeper than you think it is.
If you force the CSS to be inside the document itself, you are making it non-reusable.

That's the way fckeditor/ckeditor works. If I create a single html text with bold/italic/colour/etc I will have something like this.

<p><span style="color:#DAA520;">
<span style="font-family:lucida sans unicode,lucida grande,sans-serif;">
<strong><span style="background-color:#B22222;">This is a bold text. </span><em>
<span style="background-color:#B22222;">This is italic and bold.</span></em></strong>
</span></span></p>

If you ask for all the style from the HTML documents to be inside the basic Chamilo style, you are possibly injecting a lot of non-HTML5 CSS inside Chamilo.

Then the "static-html.css" is fine for me but it should depend of the platform (access_url) and not in the course. Right now we have a lot of those files for each course.

If you export the documents to read them offline and you have replicated 500 lines of CSS in each one, you are replicating a lot of code.

That's already the case if you create/edit styles for a html file using fckeditor.

Really, there is some merit on having a stylesheet for documents. The only thing is that we need to find a way to make it clear that this is only for documents. Something like a "print.css" but not for print. Maybe "static-html.css" or something like that.

Currently the frame.css contains a lot of useless content:
like header/footer/navs etc see

https://stable.chamilo.org/courses/01ISPRINGTEST/document/css/frames.css

#5

Updated by Julio Montoya over 5 years ago

  • Status changed from Needs more info to Rejected - Abandoned

Is too much work to do it, because we have a lot of documents that contains the frame.css file incrusted.

#6

Updated by Julio Montoya over 4 years ago

  • Status changed from Rejected - Abandoned to New
  • Target version changed from 2.0 to 1.10.0

For new documents I'm not including the frame.css file.

#7

Updated by Yannick Warnier about 4 years ago

  • Category set to Documents
  • Status changed from New to Needs testing
  • % Done changed from 0 to 90
#8

Updated by Yannick Warnier about 4 years ago

  • Status changed from Needs testing to Feature implemented
  • % Done changed from 90 to 100

Good enough for now. I'm worried about document copies (export out of Chamilo), but we'll see that in time.

Also available in: Atom PDF