Project

General

Profile

Bug #6576

appointments: moving an appointment to a different timeslot copies instead of moving

Added by Anonymous about 7 years ago. Updated about 7 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
-
Start date:
16/08/2013
Due date:
% Done:

0%

Estimated time:
Complexity:
Normal

Description

When trying to move an appointment's timeslot, the appointment is copied to the new timeslot.
screenshot: treid to move time timeslot at 9h to 10h and 11h, after which two copies of the original show up, both in the teacher's list and the student's list.


Files


Related issues

Is duplicate of Courses - Bug #6481: appointment tool: move appointment Bug resolved19/07/2013

Actions

History

#1

Updated by Anonymous about 7 years ago

in file repository/content_object/event/php/lib/appointment_mover_form.class.php on line 82, after $success &= $this -> appointment -> delete(); the $success variable has value 0, however, this is not returned, only the $new_appointment is returned, independent of the deletion success/failure status of the previous appointment.

#2

Updated by Nathalie Blocry about 7 years ago

  • Status changed from New to Rejected - Abandoned
  • Target version set to LCMS 4 Beta
#3

Updated by Anonymous about 7 years ago

  • Status changed from Rejected - Abandoned to Bug resolved

Also available in: Atom PDF