Project

General

Profile

Bug #6200

Saving anonymous user data?

Added by Julio Montoya about 8 years ago. Updated about 8 years ago.

Status:
Rejected - Abandoned
Priority:
Normal
Assignee:
-
Category:
Global / Others / Misc
Target version:
Start date:
06/06/2013
Due date:
% Done:

30%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

I found some weird SQL queries in web/index (user is not logged id)

[2013-06-06 16:51:44] chamilo.DEBUG: SELECT user_id FROM `chamilo`.`user` WHERE status = 6 {"params":[],"types":[],"executionMS":0.00019598007202148} []

[2013-06-06 16:51:46] chamilo.DEBUG: REPLACE INTO `chamilo`.`track_e_online` (login_id,login_user_id,login_date,login_ip, session_id, access_url_id)
                          VALUES (2,2,'2013-06-06 14:51:44','127.0.0.1', '0', '1')

It seems that we're saving data for the user_id = 2 which is anonymous.

I proposed to fix this and only save data for real users.

History

#1

Updated by Julio Montoya about 8 years ago

  • Status changed from New to Needs more info

Maybe there's a reason for that?

#2

Updated by Yannick Warnier about 8 years ago

  • Category set to Global / Others / Misc
  • % Done changed from 0 to 30

Yes, there is. Actually we save data for the anonymous userSSSS (all that have a status of 6). This is useful to give the anonymous user a "feeling" of what it would be like to be a registered user, by allowing him to see how long he spent in a course, how much he got at an exercise, etc.
When having a course open to the public, if you don't save anything in the database, you cannot give the anonymous user a final score and show him a "tracking" page.
When having many users not identifying themselves, you can create a "pool" of users so that, if you have 30 simultaneous users, they get an impression that they all save data independently. I'm not sure how well this works, but it is definitely not a bug to have some data stored by anonymous users.
I think this report should be rejected (in its current form).

#3

Updated by Julio Montoya about 8 years ago

  • Status changed from Needs more info to Rejected - Abandoned

Agree

Also available in: Atom PDF