Project

General

Profile

Support #6196

9.6 final - Bug reappeared : trainer (coach in a session without admin rights) can't correct a test

Added by Eric Petitdemange almost 6 years ago. Updated over 4 years ago.

Status:
Needs more info
Priority:
Normal
Assignee:
-
Category:
Exercises
Target version:
Start date:
06/06/2013
Due date:
% Done:

0%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Hi guys,

I did a clean install 1.9.6 and tried the famous correcting as a coach.
Modus operandi:
- Create a course and a test (exercise) as exam with no feedback
- Register a trainee into the course
- Create a session wher the admin is the main coach and the trainer (without admin rights)
- when the trainee answered, login as teacher, and try to correct the exam.

I put the 2 pictures : 1 when the trainer tries to correct a test, the otherone when the admin does it.
Note : both receive the notification when the trainee answered an opened question, clicking on the link is the same
I join as well the image of the session synthesis....


Files

admin_correct_test.jpg (62.7 KB) admin_correct_test.jpg Eric Petitdemange, 06/06/2013 09:31
trainer_correct_test.jpg (44.4 KB) trainer_correct_test.jpg Eric Petitdemange, 06/06/2013 09:31
session_settings.jpg (30.8 KB) session_settings.jpg Eric Petitdemange, 06/06/2013 09:31
no-admin.gif (24 KB) no-admin.gif Yoselyn Castillo, 14/06/2013 19:15
result.gif (19 KB) result.gif Yoselyn Castillo, 14/06/2013 19:15

History

#1

Updated by Yannick Warnier almost 6 years ago

  • Category set to Exercises
  • Target version set to 1.9.8
#2

Updated by Yannick Warnier almost 6 years ago

  • Assignee set to Yoselyn Castillo
#3

Updated by Eric Petitdemange almost 6 years ago

Info :
The bug with another symptoms is confirmed by a forum user :http://www.chamilo.org/phpBB3/viewtopic.php?f=14&t=4486

#4

Updated by Yoselyn Castillo almost 6 years ago

  • Status changed from New to Assigned

I suppose this is the same bug reported in issue #5881, which i could not reproduce, but i am doing other tests in order to reproduce it because i as see this has been reported many times...

#5

Updated by Eric Petitdemange almost 6 years ago

Hi,

Maybe you could give a bit of feedback on what you are performing as tests as it seems that forum user + me may be doing wrong things (even if I doubt), and you can't reproduce.

I haven't tested yet 1.9.8 nightlies, cause lack of time, but I will.

If you want to see what I'm saying, please do this one and you'll get it for sure.
I will give you the trick from Windows OS...
Get the latest WAMP for windows and install it.
From this point, go to www directory and copy a fresh unzip of 1.9.6 featured (take care as unziping can create a sub-directory!).
What I do is I unzip the archive in a temp folder and then create a Chamilo directory under www and copy/past the content of the unzipped files.

Install, make sure you don't allow hotest courses and names or catalog....

Now do what I explained in the above bug...
100% sure you get the issue (I tested on 4 different systems so I'm pretty confident doing that you will discover what happens).

Saying you made a lot of tests doesn't help me to solve the issue... :)

Thanks in advance for your time.

Oups forgot to answer regarding the #5881 ... This is/was different as here you don't get a blank page

#6

Updated by Yoselyn Castillo almost 6 years ago

As issue #5881 is solved, so we can close this too?

#7

Updated by Eric Petitdemange almost 6 years ago

No, this one is still existing 1.9.6 featured.

Only a teacher with admin rights can see the details of the exam.
Note this is starting form a complete fresh install under WAMP and under Ubuntu server LTS... Same behavior.

This is a major problem if a trainee answers opened questions as by default the platform give 0 to the specific question.

#8

Updated by Yoselyn Castillo almost 6 years ago

My feedback
In stable.chamilo.org
I have created a session
I have assigned a general coach "ycastillo" with admin rights
I have assigned a course to the session "curso2"
I have assigned a coach to the course(with the pencil in course list as you have said)"sabrine(s)" with no admin rights"
I have assigned a user to the session "mmora"
mmora has answered an open test into the session "my session"
2 mails and 2 messages were sent: to "ycastillo"(general coach with admin rights) and to "sabrine"(with no admin rights)
If ycastillo or sabrine(with or without admin rights) enter the platform messages box and access the link of the exercise, Both can correct the exam. See the image. Note this user has not admin rights

However, if ycastillo or sabrine(with or without admin rights)access through email, and they were not previously connected to platform this is the result:

I could not see the page you are showing.
Anyway i can't test in my local pc if the bug is only when correction comes form mail link, because i can not send mails.

#9

Updated by Eric Petitdemange almost 6 years ago

No, the bug is not through mail but it exists even using email...

I agree that on stable.chamilo the bug doesn't exist, but it does in my environments....
I wouldn't care of it if it was only my local PC, but the issue does exist even on my production portal.

So far I have to set the trainers with admin rights, but this is definitly not a solution.

That's really tricky as you don't occur the issue but I do.

Try a fresh install and you should get it :)

#10

Updated by Yannick Warnier over 5 years ago

  • Tracker changed from Bug to Support
  • Priority changed from Urgent to Normal
  • Target version deleted (1.9.8)

Moving as support as it cannot be reproduced in demo portals. Unassigning version: Doesn't block the release of 1.9.8

#11

Updated by Yannick Warnier over 4 years ago

  • Target version set to 2.0

Also available in: Atom PDF