Project

General

Profile

Bug #6162

Chamilo Rapid broken with LibreOffice 4

Added by Yannick Warnier about 8 years ago. Updated over 6 years ago.

Status:
Rejected - Abandoned
Priority:
Normal
Category:
Learning paths / Lecciones
Target version:
Start date:
24/05/2013
Due date:
% Done:

80%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

For some reason, it seems like moving to LibreOffice 4 broke the automatic powerpoint conversion.

To test, enable the "Rapid" plugin in admin, then launch (as documented in install guide):

sudo soffice -accept="socket,host=127.0.0.1,port=2002,tcpNoDelay=1;urp;" -headless -nodefault -nofirststartwizard -nolockcheck -nologo -norestore &

If the plugin is not enabled, it give a "cannot connect" type of error, but when you launch this command, we are showing this message:

The conversion failed.
Some documents are too complex to be threated automatically by the document converter.
We try to improve it.

This comes for lang var $OogieConversionFailed which is used in main/newscorm/openoffice_document.class.php on line 117.

This means the return value of a command similar to the following one is "2":

cd /var/www/chamilo19x/main/inc/lib/ppt2png && java -Dfile.encoding=UTF-8 -cp .:jodconverter-2.2.2.jar:jodconverter-cli-2.2.2.jar DokeosConverter -p 2002 -w 800 -h 600 -d oogie "/var/www/chamilo19x/courses/ENGLISH/document//learning_path/chamilo-intro-5m/chamilo-intro-5m.odp" "/var/www/chamilo19x/courses/ENGLISH/document/learning_path/chamilo-intro-5m.html" 

(the double // does not change anything)

The best way to try it out is to put a die($cmd) just before the exec (a few lines above 117) so the temp files are not deleted, then launching the command by hand on the command line. We then get:

24 mai 2013 10:27:31 AbstractDokeosOpenOfficeConnection connect
INFO: connected
24 mai 2013 10:27:32 AbstractDokeosOpenOfficeConnection disposing
GRAVE: disconnected unexpectedly
ERROR: conversion failed.

This seems to be a problem in Java.

Anyone with good skills in Java around?

History

#1

Updated by Jérôme Warnier about 8 years ago

  • Assignee set to Jérôme Warnier
#2

Updated by Yannick Warnier almost 8 years ago

  • Target version changed from 1.9.8 to 2.0
#3

Updated by Yannick Warnier almost 8 years ago

  • Description updated (diff)
#4

Updated by Jérôme Warnier about 7 years ago

  • Status changed from New to Needs testing
  • % Done changed from 0 to 80

Chamilo is currently using JODConverter 2.2.2 (while latest versions are 3.x, and JODConverter is not maintained anymore since 2012).
We know other people using LibreOffice 4.x with JODConverter without any problem, so this is not the problem.
It even seems that Yannick was unable to reproduce the problem on an Ubuntu 14.04 today, where it just worked flawlessly.

#5

Updated by Jérôme Warnier over 6 years ago

  • Assignee changed from Jérôme Warnier to Yannick Warnier
#6

Updated by Yannick Warnier over 6 years ago

  • Status changed from Needs testing to Rejected - Abandoned

Actually, it works fine with LibreOffice 4, now. Closing.

Also available in: Atom PDF