Project

General

Profile

Feature #6036

OpenBadges

Added by Alexander Hu over 6 years ago. Updated about 3 years ago.

Status:
Feature implemented
Priority:
Normal
Assignee:
Category:
Skills / Competencias
Target version:
Start date:
21/09/2014
Due date:
26/02/2015
% Done:

100%

Estimated time:
(Total: 52.00 h)
Spent time:
(Total: 38.00 h)
Complexity:
Normal
SCRUM pts - complexity:
20

Description

Hello everybody,

just interested to know what you think about:
http://openbadges.org/

Greets

Alex


Subtasks

Support #7389: OpenBadges Use Case diagram with high-level featuresFeature implementedLuis Salvador Lòpez Hernàndez

Actions
Support #7390: (Sprint 1) User Stories of Chamilo LMS Open Badges Plug-InFeature implementedLuis Salvador Lòpez Hernàndez

Actions
Support #7391: General Mockups for the Chamilo LMS Open-Badges Plug-inFeature implementedLuis Salvador Lòpez Hernàndez

Actions
Support #7392: Technical Report "How the Open Badges API works"Feature implementedArturo Mora-Soto

Actions
Feature #7534: (Sprint 2) Design of "Assign Capability to Exercise" Mock-upsRejected - AbandonedArturo Mora-Soto

Actions

Related issues

Related to Chamilo LMS - Feature #1791: Skills managementFeature implemented02/08/2010

Actions
Related to Chamilo LMS - Feature #7416: GamificationNew21/11/2014

Actions
Related to Chamilo LMS - Feature #7679: OpenBadges Plug-in Version 2Rejected - Abandoned05/05/201510/07/2015

Actions

History

#1

Updated by Julio Montoya over 6 years ago

Yesterday I read news about that, they reached version 1

This task is related with #1791, Yannick also suggest to use openbadges

#2

Updated by Alexander Hu over 6 years ago

Then i would reccomend to implement that fast, because it would be a HUGE step forward to gain reputation and public relations ;-)
(although i don't know how much this would be to implement; but i already asked about funding... i have many clients which want special things... ;-) )

#3

Updated by Yannick Warnier over 6 years ago

  • Status changed from New to Rejected - Abandoned

I'm going to close this task, otherwise we're going to have split work. Please continue discussing in #1791 (where I'm adding information now)

#4

Updated by Yannick Warnier about 5 years ago

  • Category set to Skills / Competencias
  • Status changed from Rejected - Abandoned to Assigned
  • Assignee set to Arturo Mora-Soto
  • Target version set to 1.10.0
#5

Updated by Yannick Warnier about 5 years ago

The other task having been implemented without OpenBadges, we are re-opening this one. Arturo has two students working on this, who will be reporting and uploading stuff here.

#6

Updated by Arturo Mora-Soto about 5 years ago

  • SCRUM pts - complexity changed from ? to 20
#9

Updated by Yannick Warnier about 5 years ago

Thanks for the links.
The implementation of OpenBadges in Chamilo should be slightly different from Moodle and Claroline in that, differently from these two, we already have a skills management system to which we need to connect OpenBadges.

This being said, after checking very quickly the two links (Moodle and Claroline), I think the Moodle one is more interesting to us. In particular, there are several things that we need to think about to make it complete:
  • push badges to Mozilla OpenBadges
  • pull badges from other portals
  • decide whether a badge is shown publicly or not

The main item of discussion to start with is authentication and whether we integrate an authentication mechanism from Symfony (which I am afraid will act as a snowball and will force us to implement much more Symfony components as we've seen it happen for the development of v10) or whether we temporarily inject an OAuth2 library (and we replace it with an authentication component from Symfony later on when moving to v10).

The issue is that we would need at least a partial implementation now as we have a customer that clearly needs it (although he doesn't spell it), and because we should enjoy the opportunity to try it out and see the impact it can have (which I assume will be quite large).

#10

Updated by Alexander Hu about 5 years ago

if somebody is looking for inspiration about badge design:
http://moodlebadges.com/?page_id=17

#11

Updated by Yannick Warnier almost 5 years ago

  • Assignee changed from Arturo Mora-Soto to Angel Quiroz
#12

Updated by Arturo Mora-Soto almost 5 years ago

  • Assignee changed from Angel Quiroz to Arturo Mora-Soto
#13

Updated by Yannick Warnier over 4 years ago

Arturo, any update?

#14

Updated by Yannick Warnier over 4 years ago

Arturo, we will only be able to wait for 2 more weeks before integrating whatever your team has done. Is there any progress?

#15

Updated by Yannick Warnier over 4 years ago

  • Status changed from Assigned to Feature implemented
  • Assignee changed from Arturo Mora-Soto to Angel Quiroz

I'm closing this task for 1.10.x for lack of feedback. A new task should be created for 2.0, or some updates posted here very soon.

#16

Updated by Arturo Mora-Soto over 4 years ago

Hi there,

If the deadline is two week to incorporate our code, I think there is no enough functionality to add. Due to the lack of experience of my current development team at CIMAT they were not able to code as fast as I wanted. Right now they are dealing with OpenBadges API and designing a kind of Chamilo LMS API to publish badges from Chamilo to Mozilla Backpack.

So that, I believe the best option is to include the code done by us at CIMAT in the next version in order to include full functionality of the new plug-in.

Also available in: Atom PDF