Project

General

Profile

Bug #5944

Fatal error en algunos idiomas en transtalte.chamilo.org

Added by Noa Orizales Iglesias about 7 years ago. Updated about 7 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
-
Category:
Translations
Target version:
-
Start date:
05/02/2013
Due date:
% Done:

0%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Hola, Al acceder a http://translate.chamilo.org e ir a traducir el idioma catalán, se produce el error:

Fatal error: Call to a member function get_variable() on a non-object in /var/www/translate.chamilo.org/www/application/lib/cda/forms/variable_translation_form.class.php on line 37 Call Stack: 0.0012 345304 1. {main}() /var/www/translate.chamilo.org/www/run.php:0 0.2666 8941000 2. CdaManager->run() /var/www/translate.chamilo.org/www/run.php:38 0.2857 10347012 3. CdaManagerVariableTranslationUpdaterComponent->run() /var/www/translate.chamilo.org/www/application/lib/cda/cda_manager/cda_manager.class.php:203 0.3155 11499132 4. VariableTranslationForm->VariableTranslationForm() /var/www/translate.chamilo.org/www/application/lib/cda/cda_manager/component/variable_translation_updater.class.php:46 0.3255 11818644 5. VariableTranslationForm->build_basic_form() /var/www/translate.chamilo.org/www/application/lib/cda/forms/variable_translation_form.class.php:28

Pasa, como mínimo, con el catalán, el inglés y el gallego. Un ejemplo de idioma en el que no sucede es el "basque"

History

#1

Updated by Emiliano Orizales about 7 years ago

Hola Andreu:
Este tema ya está en cartera. La herramiente es antigua y hay que actualizarla, pero no se puede hacer por razones técnicas antes de llegar a la versión 1.10 y lo del 99% parece ser que alguien agregó una palabra en otro idioma en la traducción de inglés y francés por eso sale así (esto es lo que me contestó Yannick cuando se me presentó este problema a mi).
A mi me pasó lo mismo que a ti pero con el gallego.Pero todo funciona correctamente. Ese error lo da una vez has realizado toda la traducción y llegas al final. Tambien te pondrá que está al 99%. Tienes que entrar dentro de tu idioma, catalán en este caso, y comprobar que todos los apartados están al 100% si es así todo correcto. Si hay alguno que no está al 100% tienes que entrar en ese en particular y realizar la traducción correspondiente, cuando llegues al final te da error de nuevo pero no hay problema todo está correcto. Verás que ese apartado lo pone al 100% aunque el general de catalán ponga 99%.

Un saludo

Emiliano

#2

Updated by Noa Orizales Iglesias about 7 years ago

  • Status changed from New to Bug resolved
#3

Updated by Andreu de Haro about 7 years ago

Hola Emiliano, muchas gracias! Ahora mismo lo probaré.

Emiliano Orizales wrote:

Hola Andreu:
Este tema ya está en cartera. La herramiente es antigua y hay que actualizarla, pero no se puede hacer por razones técnicas antes de llegar a la versión 1.10 y lo del 99% parece ser que alguien agregó una palabra en otro idioma en la traducción de inglés y francés por eso sale así (esto es lo que me contestó Yannick cuando se me presentó este problema a mi).
A mi me pasó lo mismo que a ti pero con el gallego.Pero todo funciona correctamente. Ese error lo da una vez has realizado toda la traducción y llegas al final. Tambien te pondrá que está al 99%. Tienes que entrar dentro de tu idioma, catalán en este caso, y comprobar que todos los apartados están al 100% si es así todo correcto. Si hay alguno que no está al 100% tienes que entrar en ese en particular y realizar la traducción correspondiente, cuando llegues al final te da error de nuevo pero no hay problema todo está correcto. Verás que ese apartado lo pone al 100% aunque el general de catalán ponga 99%.

Un saludo

Emiliano

Also available in: Atom PDF