Project

General

Profile

Bug #5881

Link when opened question is answered opens a blank page

Added by Eric Petitdemange about 8 years ago. Updated over 7 years ago.

Status:
Bug resolved
Priority:
High
Assignee:
Yoselyn Castillo
Category:
Exercises
Target version:
Start date:
18/01/2013
Due date:
% Done:

70%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Hi guys,

Using 1.9.4 (nightly, but this may exist also in 1.9.4 stable - have to double check), when I'm notified a student answer opened questions, if I click on the link to correct the exam it opens a blank page.

I cleaned up the Archive directory :)


Files

correction1.jpg (44.5 KB) correction1.jpg Eric Petitdemange, 25/01/2013 13:48
correction2.jpg (30.2 KB) correction2.jpg Eric Petitdemange, 25/01/2013 13:48
correction3.jpg (28.5 KB) correction3.jpg Eric Petitdemange, 25/01/2013 13:48

Associated revisions

Revision 13fe5714 (diff)
Added by Julio Montoya about 8 years ago

Should fix bug when correcting an exercise see #5881

History

#1

Updated by Eric Petitdemange about 8 years ago

  • Priority changed from High to Immediate

Impossible to access to correcting the exam, the page remains blank even when trying to correct the test.

This is an exam, I really need your help please.

#2

Updated by Julio Montoya about 8 years ago

  • Status changed from New to Needs more info

I tried to reproduced the errror in my local installation but it works fine. Can you try to reproduce the error in stable.chamilo.org?

#3

Updated by Eric Petitdemange about 8 years ago

You went too fast Julio, thanks,

Here was the update I wanted to create...

OUPS, I put it to need more info, I see the student is remained connected on the platform....

If this is the case, this mean tha I may change this to feature request:

We receive an email saying that a trainee answered questions, nothing alerts that the user is still in use of the test (just something that would tell on the platform the stident didn't disconnect from the platform).

I give you feedback ASAP !

So we stand by :)

#4

Updated by Eric Petitdemange about 8 years ago

Je confirme le bug, impossible de corriger le test, l'étudiant n'est plus connecté.

#5

Updated by Eric Petitdemange about 8 years ago

Info complémentaire, je m'en sors car j'avais mis 2 coaches (OUF !)

Oups I follow in english as started in english...
What I occur here:

Created a session with 1 trainee, 1 "main coach" declared while creating the session.
Added a coach (I'll now do it all the time!!!) using the pencil in regards with the course.

If I login as the main coach : blank page, impossible to correct the test
if I login as spair coach, I do manage to correct the test.

#6

Updated by Eric Petitdemange about 8 years ago

  • Priority changed from Immediate to High

I put it as High as there is an overcome : having a second coach.

Note both coaches are Admin, and one of the two is the admin that installed the platform (so the login is admin).

Hope this helps to troubleshoot if needed.

As far as I see, test without opened question doesn't have the issue.

#7

Updated by Eric Petitdemange about 8 years ago

OK I need to test using 1.9.4 stable, but I just figured out that the declared coach (the one put when creating the session) has access to correct the test, but if you declare spare coaches (using the pencil to declare the coach(es) in course list)get a blank page when they try to correct the test, regardless of type of questions.

#8

Updated by Eric Petitdemange about 8 years ago

Last but not least :)
If you set the same coach both when creating the session and as spare coach, He gets a blank page when trying to access correction.

#9

Updated by Yannick Warnier about 8 years ago

  • Category set to Exercises
  • Target version set to 1.9.6
#10

Updated by Julio Montoya about 8 years ago

effectivement je viens de voir le bug

#11

Updated by Julio Montoya about 8 years ago

  • Status changed from Needs more info to Needs testing
  • % Done changed from 0 to 70

je viens d'envoyer une correction pour ca

#12

Updated by Eric Petitdemange about 8 years ago

OK merci Julio, j'attends la nightly.
Espérant pouvoir faire une mise à jour de ma 1.9.4 sans risque :)

#13

Updated by Yannick Warnier about 8 years ago

Coursenligne 45 wrote:

OK merci Julio, j'attends la nightly.
Espérant pouvoir faire une mise à jour de ma 1.9.4 sans risque :)

Je serais toi j'attendrais quand même quelques jours avant de... mettre à jour. Comme on vient de terminer la 1.9.4, on se permet généralement (juste après) de mettre un peu d'ordre et parfois ça casse quelques trucs. Si tu es en production avec ta 1.9.4, attends encore un peu.

#14

Updated by Eric Petitdemange about 8 years ago

Bien entendu je vais attendre :)

Cela ne fonctionne pas à 100% de mon côté :
- un administrateur que je mets en coach sur la session (lors de la création) : peut corriger sans problème
- un formateur (sans droits d'admin) mis en coach supplémentaire : arrive au corrigé, mais a le message visible sur l'image "correction1".
S'il clique sur corriger le test, alors le score est à 0 (voir "correction 2").

Heureusement, l'admin principal a toujours accès et peut corriger le test (c'est bien d'avoir possibilité de contre-corriger).

Quand j'ai vu le lien back to test tools, j'ai cliqué dessus, cela amène vers la création de tests mais également le suivi (icone histogramme), mais cela affiche le test comme "validated", si je clique sur le crayon (en tant que coach secondaire), je retourne en boucle sur "correction1".

Si je donne les droits d'admin à mon formateur alors il a bien accès à la correction.

Si je mets le formateur (sans droits d'admin) en coach principal, il reçoit le message visible sur "correction 3". L'administrateur en coach secondaire peut corriger.

Bref il faut les droits admin pour que cela fonctionne.
Le bug est presque résolu vu de ma fenêtre.
En tout cas, il est possible de fonctionner ainsi.

#15

Updated by Yannick Warnier almost 8 years ago

  • Status changed from Needs testing to New
#16

Updated by Yannick Warnier almost 8 years ago

  • Target version changed from 1.9.6 to 1.9.8
#17

Updated by Yannick Warnier over 7 years ago

  • Assignee set to Yoselyn Castillo
#18

Updated by Yoselyn Castillo over 7 years ago

  • Status changed from New to Needs more info

In stable.chamilo.org
I have created a session "mysession"
I have assigned a general coach "ycastillo" with admin rights
I have assigned a course to the session "curso2"
I have assigned a coach to the course(with the pencil in course list as you have said)"sabrine(s)" with no admin rights"
I have assigned a user to the session "mmora"
mmora has answered an open test into the session "my session"
2 mails were sent: one to "ycastillo"(general coach with admin rights) and other to "sabrine"(with no admin rights)
Both of them could correct the exam no blank pages shown.
Did I missed any step or anything else?
Please tell me which is specifically the bug, if you can try it in stable.chamilo.org

#19

Updated by Eric Petitdemange over 7 years ago

Hi,

Please ensure stable.chamilo is not using a new brand ;)

It is related to non-admin trainers don't have access to the details of the correction.

I don't know what happens, as the bug is not always present.
I'll upgrade my production and pre-prod as soon as I have a bit of time, using 1.9.6 stable (remember this is based on 1.9.4 that was the latest stable version when these lines were written).

#20

Updated by Yoselyn Castillo over 7 years ago

Ok, please notify me your feedback when you make tests with the last version, in order to know where is the problem

#21

Updated by Eric Petitdemange over 7 years ago

  • Status changed from Needs more info to Bug resolved

OK so far I couldn't reproduce the issue using 1.9.6 featured, this was on 1.9.4....
I set the case closed and if the issue reappers, I'll let you know

#22

Updated by Eric Petitdemange over 7 years ago

No, this one is still existing 1.9.6 featured.

Only a teacher with admin rights can see the details of the exam.
Note this is starting form a complete fresh install under WAMP and under Ubuntu server LTS... Same behavior.

This is a major problem if a trainee answers opened questions as by default the platform give 0 to the specific question.

#23

Updated by Eric Petitdemange over 7 years ago

OUps sorry thsi answer is for 5968..I copy it in the right case.

#24

Updated by Yoselyn Castillo over 7 years ago

Coursenligne 45 wrote:

OK so far I couldn't reproduce the issue using 1.9.6 featured, this was on 1.9.4....
I set the case closed and if the issue reappers, I'll let you know

So that means we can close5968?

#25

Updated by Yoselyn Castillo over 7 years ago

Ok, i think i understand now, this issue continues as bug resolved and, the bug you are talking about which reamins is issue #6196, and issue #5968 is other thing. Am I right?

#26

Updated by Eric Petitdemange over 7 years ago

You got it...

The blank page seems to be gone, but non admin trainer can't correct exams :)

Also available in: Atom PDF