Project

General

Profile

Bug #5772

When publishing a Survey, we always have to fill MailSubject and MailBody fields

Added by Hubert Borderiou about 9 years ago. Updated almost 9 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
Yoselyn Castillo
Category:
Survey
Target version:
Start date:
27/11/2012
Due date:
% Done:

50%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Hi,
I've got a course
I've created a Survey.
I want to publish my survey but without sending a mail.
I unchecked checkbox Send mail
but I still have to fill fields Mail Subject and Mail Body
See attached.


Files

2012-11-27_1742.png (53.8 KB) 2012-11-27_1742.png Hubert Borderiou, 27/11/2012 17:44
survey_invite.php (9.73 KB) survey_invite.php Yoselyn Castillo, 29/11/2012 18:25
survey_invite.php (9.54 KB) survey_invite.php Yoselyn Castillo, 03/12/2012 18:20
survey_invite.php (10.4 KB) survey_invite.php Yoselyn Castillo, 04/12/2012 17:06

Associated revisions

Revision eaf32ec7 (diff)
Added by Yoselyn Castillo about 9 years ago

Fixes MailSubject and MailBody fields see #5772

Revision 6b3aecf1 (diff)
Added by Yoselyn Castillo almost 9 years ago

When publishing a Survey, we always have to fill MailSubject and MailBody fields see #5772

Revision 3d7312cc (diff)
Added by Yoselyn Castillo almost 9 years ago

When publishing a Survey, we always have to fill MailSubject and MailBody fields see #5772

History

#1

Updated by Yoselyn Castillo about 9 years ago

  • Status changed from New to Assigned
  • Assignee set to Yoselyn Castillo

Checking

#2

Updated by Yoselyn Castillo about 9 years ago

I have changed the way to fill title and mail text, they are only necessary if checkbox send_mail is checked.

#3

Updated by Julio Montoya about 9 years ago

  • Status changed from Assigned to Needs more info
  • Assignee deleted (Julio Montoya)

File was sent

#4

Updated by Yoselyn Castillo almost 9 years ago

  • Status changed from Needs more info to Needs testing
#5

Updated by Yoselyn Castillo almost 9 years ago

The result of the test...
When you publish a survey, if you want to send an email, check the checkbox send_mail and you have to fill mail_title and mail_text else if you don't want to send mail uncheck the checkbox and fields mail_title and mail_text are hidden.
However, confirmation message is showing wrong number of users invited. Checking...

#6

Updated by Yoselyn Castillo almost 9 years ago

  • Status changed from Needs testing to Assigned
#7

Updated by Yoselyn Castillo almost 9 years ago

  • Assignee set to Yoselyn Castillo

When sending mail is checked invitations are not sent now. Fixing...

#8

Updated by Yoselyn Castillo almost 9 years ago

Fixed. Upload this

#9

Updated by Julio Montoya almost 9 years ago

  • Status changed from Assigned to Needs testing
  • Assignee deleted (Julio Montoya)
  • % Done changed from 0 to 50

File uploaded

#10

Updated by Yoselyn Castillo almost 9 years ago

There was a bug when invitations couldn't be sent due to blank fields. Fixed. Fixed a problem with the number of users invited in the message displayed too. upload this. Thanks

#11

Updated by Julio Montoya almost 9 years ago

  • Status changed from Assigned to Needs more info
  • Assignee changed from Julio Montoya to Yoselyn Castillo

file was sent

#12

Updated by Yoselyn Castillo almost 9 years ago

  • Status changed from Needs more info to Bug resolved

It works fine, when you publish a survey you can choice if send email or not, so you have to fill or not the fields subject and text of mail. Number of invited users is fixed too.

Also available in: Atom PDF