Project

General

Profile

Bug #5692

Login as show previous user in username (top left)

Added by Yannick Warnier almost 9 years ago. Updated almost 9 years ago.

Status:
Bug resolved
Priority:
High
Assignee:
-
Category:
Global / Others / Misc
Target version:
Start date:
04/11/2012
Due date:
% Done:

100%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

In 1.9.4 (stable.chamilo.org), when "logging as" another user, the name of the user appears to be the one from the user we used before. This value should be flushed (if it is cached at some point) when logging as another user


Files

template.lib.php (27.3 KB) template.lib.php Yoselyn Castillo, 21/11/2012 15:20

History

#1

Updated by Yoselyn Castillo almost 9 years ago

I am going to check and i will give you my feedback...

#2

Updated by Yoselyn Castillo almost 9 years ago

  • File template.lib.php added
  • % Done changed from 0 to 70

It seems $GLOBALS has any problem. Upload this change.

#3

Updated by Julio Montoya almost 9 years ago

  • Assignee changed from Julio Montoya to Yoselyn Castillo

Did you tried with:

$user_info = api_get_user_info(api_get_user_id());

_api_format_user() should be used only inside the api_get_user_info() function
Also the api_get_user_info() should be preferred instead of the Usermanager::get_user_info_by_id()

I'm updating the documentation.

#4

Updated by Yoselyn Castillo almost 9 years ago

Oh, I didn't know that specifications. This is the correct change :-)

#5

Updated by Yoselyn Castillo almost 9 years ago

  • File deleted (template.lib.php)
#6

Updated by Julio Montoya almost 9 years ago

  • Status changed from Assigned to Bug resolved
  • Assignee deleted (Julio Montoya)
  • % Done changed from 70 to 100

fix sent

Also available in: Atom PDF