Project

General

Profile

Bug #5463

L'activation d'openID génère une erreur 500

Added by Franck Gauttron almost 7 years ago. Updated almost 7 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
14/09/2012
Due date:
% Done:

70%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

L'activation de l'authentification par openid dans les paramètres d'administration génère une erreur de serveur 500.

Version Chamilo : 1.9.0
Php 5.3
Mysql 5.1
Serveur mutualisé


Related issues

Related to Chamilo LMS - Bug #5500: Problem with login when using openidNew19/09/2012

Actions

Associated revisions

Revision b62bb59f (diff)
Added by Julio Montoya almost 7 years ago

Fixing openid mysql errors see #5463

History

#1

Updated by Marko Kastelic almost 7 years ago

error 500 is very general error. Could you supply more info from http server error log, php error log ... ?

#2

Updated by Franck Gauttron almost 7 years ago

Voici les infos :

Fatal error: require_once() [function.require]: Failed opening required '/homez.342/cefim/www/campus/main/auth/openid../../inc/conf/auth.conf.php' (include_path='/homez.342/cefim/www/campus/main/inc/lib/htmlpurifier/library:.:/homez.342/cefim/www/campus/main/inc/lib/pear:/usr/local/lib/php') in /homez.342/cefim/www/campus/main/auth/openid/login.php on line 15

#3

Updated by Marko Kastelic almost 7 years ago

confirming this bug.

Franck Gauttron wrote:

Voici les infos :

Fatal error: require_once() [function.require]: Failed opening required '/homez.342/cefim/www/campus/main/auth/openid../../inc/conf/auth.conf.php' (include_path='/homez.342/cefim/www/campus/main/inc/lib/htmlpurifier/library:.:/homez.342/cefim/www/campus/main/inc/lib/pear:/usr/local/lib/php') in /homez.342/cefim/www/campus/main/auth/openid/login.php on line 15

next part of the path from your report shows missing / delimiter in path
/homez.342/cefim/www/campus/main/auth/openid../../inc/conf/auth.conf.php

open main/auth/openid/login.php
and change line 15 from
require_once dirname(FILE).'../../inc/conf/auth.conf.php';
to
require_once dirname(FILE).'/../../inc/conf/auth.conf.php';

and please report back if auth(s) were successful-

#4

Updated by Yannick Warnier almost 7 years ago

  • Target version set to 1.9.2
#5

Updated by Marko Kastelic almost 7 years ago

... after unsuccessful login (wrong openID, wrong openID url) transferred to page is without portal header, footer and return link

#6

Updated by Franck Gauttron almost 7 years ago

Après connexion avec un identifiant openid, on a le message d'erreur suivant :

Dev message: please add the c_id field in this query or report this error in support.chamilo.org

SELECT assoc_handle FROM `oxfinance_campus`.`openid_association` WHERE idp_endpoint_uri = '%s'
Openid login redirection should be in progress

#7

Updated by Julio Montoya almost 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Julio Montoya

checking

#8

Updated by Julio Montoya almost 7 years ago

  • Status changed from Assigned to Needs testing
  • Assignee deleted (Julio Montoya)
  • % Done changed from 0 to 50

I sent some fixes

#9

Updated by Yoselyn Castillo almost 7 years ago

  • Assignee set to Yoselyn Castillo
#10

Updated by Yoselyn Castillo almost 7 years ago

The activation doesn't generate the bug now, but the page after unsuccessful login(wrong OPENID) still continues without header, etc as Marko has said.

#11

Updated by Yannick Warnier almost 7 years ago

Please open a new task (for 1.10) with the error-without-header issue, so that we can close this one.
In the new task, add a "Related issue" with the ID of this one here (#5463)

#12

Updated by Yoselyn Castillo almost 7 years ago

  • Status changed from Needs testing to Bug resolved
  • Assignee deleted (Yoselyn Castillo)
  • % Done changed from 50 to 70

The fatal error was removed. So rest of problem of this task will be ressolved in task 5500

Also available in: Atom PDF