Project

General

Profile

Bug #5394

Error enviando anuncios a un grupo en chamilo 1.9.0 (Announcement bug)

Added by Pablo Gamez almost 7 years ago. Updated almost 7 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
31/08/2012
Due date:
% Done:

50%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Hola!

Cuando intento enviar un anuncio desde el menú principal a un grupo en chamilo 1.9.0, envía el anuncio solo a los componentes del grupo y el correo a todos los componentes del curso (tanto en red social como correo electrónico).

Si entro en un grupo y desde ahí envió la notificación no sucede este problema y solamente envía tanto el anuncio como el correo a los componentes del grupo.


Related issues

Related to Chamilo LMS - Bug #5430: Announcements to group: wrong number of recipientsBug resolved07/09/2012

Actions

Associated revisions

Revision 4654420d (diff)
Added by Julio Montoya almost 7 years ago

Should fix bug when sending announcements see #5394

History

#1

Updated by Pablo Gamez almost 7 years ago

Reparado por mi compañero programador. Error al hacer las búsquedas en el fichero /main/announcements/announcement_email.class.php

La funcion public sent_to no hacia bien la consulta a quien se envía

public function sent_to()
    {
$sent_to = $this->sent_to_info();
$users = $sent_to['users'];
$users = $users ? $users : array();
$groups = $sent_to['groups'];
if ($users) {
$users = UserManager::get_user_list_by_ids($users, true);
}
if (!empty($groups)) {
$group_users = GroupManager::get_groups_users($groups);
$group_users = UserManager::get_user_list_by_ids($group_users, true);
$users = array_merge($users, $group_users);
}
if (empty($users)) {
$users = self::all_users();
}
#2

Updated by Julio Montoya almost 7 years ago

  • Status changed from New to Needs testing
  • Assignee set to Yoselyn Castillo
  • % Done changed from 0 to 50

Arreglo enviado a Chamilo 1.9.2 Gracias por reportar

#4

Updated by Julio Montoya almost 7 years ago

  • Target version set to 1.9.2
#5

Updated by Yoselyn Castillo almost 7 years ago

  • Status changed from Needs testing to Bug resolved
  • Assignee deleted (Yoselyn Castillo)

Tested! It works fine.
I have created 2 users.
In a course I have added these two users.
Later I have created a new group, with only one of those users.
I have sent an announcement to the group.
It was only received by the user incribed in the group.
I have inscribed the other user too.
I have sent an announcement to the group.
It was only received by the two users of the group.

#6

Updated by Julio Montoya almost 7 years ago

  • Subject changed from Error enviando anuncios a un grupo en chamilo 1.9.0 to Error enviando anuncios a un grupo en chamilo 1.9.0 (Announcement bug)

Also available in: Atom PDF