Project

General

Profile

Bug #5265

Editing a document in full view in LP without title blanks page

Added by Yannick Warnier almost 7 years ago. Updated almost 6 years ago.

Status:
Bug resolved
Priority:
Normal
Category:
-
Target version:
Start date:
28/07/2012
Due date:
% Done:

90%

Estimated time:
1.00 h
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

In a learning path, create a new "document", leave the title empty. Click on the WYSIWYG editor maximizer icon and write some text. Click on the "Save" icon -> the text is deleted.


Files

lp_add_item.php (11.6 KB) lp_add_item.php Yoselyn Castillo, 04/08/2012 08:21

Associated revisions

Revision de46654c (diff)
Added by Julio Montoya almost 7 years ago

Minor - removing save button in fkceditor that doesn't work see #5265

Revision f51a175c (diff)
Added by Yoselyn Castillo almost 7 years ago

Fixing fckeditor blank content bug in LP see #5265

Revision 3cfed547 (diff)
Added by Yannick Warnier almost 6 years ago

Fixed regression from 1.9.0 whereby the templates selector didn't appear in learning path item creation - refs #5265

History

#1

Updated by Yannick Warnier almost 7 years ago

  • Subject changed from Editing a document in full viw in LP without title blanks page to Editing a document in full view in LP without title blanks page
#2

Updated by Yoselyn Castillo almost 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Yoselyn Castillo
#3

Updated by Julio Montoya almost 7 years ago

  • Status changed from Assigned to Needs more info
  • % Done changed from 0 to 70

Any news for this task? I "fixed" this just removing the save button here:

main/inc/lib/fckeditor/toolbars/extended/learning_path_documents.php line +24

#4

Updated by Yoselyn Castillo almost 7 years ago

There is no save icon now, but when you click on create document without title, the text in fckeditor is deleted too. is this right?

#5

Updated by Julio Montoya almost 7 years ago

the bug still remains :(, yes, you're right

#6

Updated by Yoselyn Castillo almost 7 years ago

I am testing a solution

#7

Updated by Yoselyn Castillo almost 7 years ago

Upload this file. It Fixes the problem

#8

Updated by Yoselyn Castillo almost 7 years ago

  • Assignee changed from Yoselyn Castillo to Julio Montoya
  • % Done changed from 70 to 90
#9

Updated by Yoselyn Castillo almost 7 years ago

Upload the lp_add_item.php file previously attached

#10

Updated by Julio Montoya almost 7 years ago

  • Status changed from Needs more info to Needs testing
  • Assignee changed from Julio Montoya to Yoselyn Castillo

File uploaded, works for me

#11

Updated by Yoselyn Castillo almost 7 years ago

  • Status changed from Needs testing to Bug resolved

Fixed

#12

Updated by Yannick Warnier almost 6 years ago

This path was reverted. Yoselyn, please do NOT comment out code when you don't know what it does. In this case, you commented as section of the code which makes the document templates appear on the ledt side.
I can't understand how nobody could catch that (it's been one year already), and I know you're more careful now. Just try to avoid this kind of feature loss, as it is very difficult to check through unit tests (so it is easily missed by us developers).
Apparently the problem was somewhere else and was fixed there, as I can now do what is described as problematic in this issue's description without having the same problem, so I'm leaving it closed.

Also available in: Atom PDF