Project

General

Profile

Bug #5194

Internet Explorer 9 doesn't show Cosmic Campus menu background image

Added by Juho Paranko about 7 years ago. Updated about 7 years ago.

Status:
Bug resolved
Priority:
Low
Assignee:
-
Category:
-
Target version:
Start date:
15/07/2012
Due date:
% Done:

70%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Internet Explorer 9 doesn't show the menu background image of Cosmic Campus theme. See the attached screenshots.

This is because in css/base.css

.subnav {
filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#f5f5f5', endColorstr='#eeeeee',GradientType=0 ); /* IE6-9 */
}

has priority over

.subnav {
background: url("images/fondoHeader3.jpg") repeat scroll 0 0 #FFFFFF;
}

that is in css/cosmic_campus/default.css.


Files

CosmicCampus_IE9.jpg (53.2 KB) CosmicCampus_IE9.jpg Screenshot IE9 Juho Paranko, 15/07/2012 20:04
CosmicCampus_Firefox.jpg (61.8 KB) CosmicCampus_Firefox.jpg Screenshot Firefox Juho Paranko, 15/07/2012 20:04
base.css (85.8 KB) base.css Yoselyn Castillo, 29/07/2012 05:52

History

#1

Updated by Juho Paranko about 7 years ago

This is in Chamilo 1.9

#2

Updated by Yoselyn Castillo about 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Yoselyn Castillo
#3

Updated by Yoselyn Castillo about 7 years ago

  • File base.css base.css added
  • Assignee changed from Yoselyn Castillo to Julio Montoya

Upload this css, this makes the difference between IE and the rest of browsers

#4

Updated by Julio Montoya about 7 years ago

  • Assignee changed from Julio Montoya to Yoselyn Castillo

Can you tell me where was exactly the change? I just updated the base.css file

#5

Updated by Yoselyn Castillo about 7 years ago

the change is below the comment/*subnav*/

This code

.subnav{
height: 36px;
background-image: -ms-linear-gradient(top, #f5f5f5 0%,#eeeeee 100%); /* IE10+ */
border: 1px solid #e5e5e5;
}
html>body.subnav {
height: 36px;
-webkit-border-radius: 4px;
-moz-border-radius: 4px;
border-radius: 4px;

/* default subnav color /
background-color: #eeeeee; /
Old browsers /
background-repeat: repeat-x; /
Repeat the gradient /
background-image: -moz-linear-gradient(top, #f5f5f5 0%, #eeeeee 100%); /
FF3.6+ /
background-image: -webkit-gradient(linear, left top, left bottom, color-stop(0%,#f5f5f5), color-stop(100%,#eeeeee)); /
Chrome,Safari4+ /
background-image: -webkit-linear-gradient(top, #f5f5f5 0%,#eeeeee 100%); /
Chrome 10+,Safari 5.1+ /
background-image: -o-linear-gradient(top, #f5f5f5 0%,#eeeeee 100%); /
Opera 11.10+ /
filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#f5f5f5', endColorstr='#eeeeee',GradientType=0 ); /
IE6-9 /
background-image: linear-gradient(top, #f5f5f5 0%,#eeeeee 100%); /
W3C /
border: 1px solid #e5e5e5;
/
end default subnav background colors */
}
#6

Updated by Yoselyn Castillo about 7 years ago

  • Assignee changed from Yoselyn Castillo to Julio Montoya
#7

Updated by Julio Montoya about 7 years ago

  • Status changed from Assigned to Needs testing
  • Assignee deleted (Julio Montoya)
  • % Done changed from 0 to 70

I fixed that issue, I replace the current image background with CSS styles

#8

Updated by Yannick Warnier about 7 years ago

  • Target version set to 1.9.4
#9

Updated by Julio Montoya about 7 years ago

  • Status changed from Needs testing to Bug resolved

seems to be fixed, closing for lack of feedback

Also available in: Atom PDF