Project

General

Profile

Bug #5060

CKeditor CO insert RSS

Added by dominique de guchtenaere about 7 years ago. Updated about 6 years ago.

Status:
New
Priority:
Normal
Assignee:
Start date:
26/06/2012
Due date:
% Done:

0%

Estimated time:
Complexity:
Normal

Description

In a CO doucment type, I want to insert a RSS via the button Insert CO in the CKeditor.
Seems to work fine, until I click the "create" button at bottom: I get a blanc screen and the CO (document type) isn't created.
The RSS feed is added.


Files

rss_CO_in_DocType.png (25.3 KB) rss_CO_in_DocType.png dominique de guchtenaere, 29/06/2012 10:28
rss_in_CO.png (25.3 KB) rss_in_CO.png dominique de guchtenaere, 02/07/2012 14:06

History

#1

Updated by Stefaan Vanbillemont about 7 years ago

  • Target version set to Backlog (default)
#2

Updated by Anthony Hurst about 7 years ago

Fatal error: Cannot make static method repository\content_object\rss_feed\RenditionImplementation::parse_file() non static in class repository\content_object\rss_feed\HtmlInlineRenditionImplementation in C:\wamp\www\chamilo-work\repository\content_object\rss_feed\php\lib\implementation\rendition\html\inline.class.php on line 11

#3

Updated by Anthony Hurst about 7 years ago

  • Status changed from New to Needs testing
  • Assignee set to dominique de guchtenaere
  • Target version changed from Backlog (default) to LCMS 3

Corrections made. Please retest.

#4

Updated by dominique de guchtenaere about 7 years ago

The problem of the blanc screen is resolved. Now, when I open the created CO document-type, I get a really messed up html page (see screenshot)

#5

Updated by Anthony Hurst about 7 years ago

  • Status changed from New to Needs more info
  • Assignee changed from Anthony Hurst to dominique de guchtenaere

Would it be possible to reproduce this on the official test site and provide us with a link, please? It would be a great help, as I haven't been able to reproduce it on my own installation.

#6

Updated by dominique de guchtenaere about 7 years ago

  • Status changed from Needs more info to New
  • Assignee changed from dominique de guchtenaere to Anthony Hurst
#7

Updated by Michael Hosdez about 7 years ago

The main problem is the HTML link, see also issue #4945

What happens?
You need to click the HTML link to see the content of the file, when doing so the HTML file is downloaded to a TEMP folder on the local computer what results in an incomplete HTML source (no header, body, etc) because the HTML file needs to be opened within the C3 lay-out.

References to the CSS file (for the correct rendering) are not implemented in the HTML file, in the above example:
background-image: ... results in a endless repeated background.

My opinion? Fix issue #4945 so HTML (and PDF) files are immediately visible within the C3 layout and all issues are gone.

#8

Updated by Stefaan Vanbillemont about 7 years ago

  • Status changed from New to Needs testing
  • Assignee changed from Anthony Hurst to Michael Hosdez

Can you please retest? Some changes where made ..

#9

Updated by Anonymous about 7 years ago

Appears to work just fine.

#10

Updated by Stefaan Vanbillemont about 7 years ago

  • Status changed from Needs testing to Bug resolved
#11

Updated by dominique de guchtenaere about 7 years ago

  • File rss_in_CO.png rss_in_CO.png added
  • Status changed from Bug resolved to New
  • Assignee changed from Michael Hosdez to Anthony Hurst

I just tested it on the online test platform, and the rss still shows the icons all over the page. (see screen shot)

#12

Updated by dominique de guchtenaere about 7 years ago

retested on the latest online c3dev.chamilo.org. Same issue.

#13

Updated by Stefaan Vanbillemont about 7 years ago

  • Target version changed from LCMS 3 to Backlog (default)
#14

Updated by Anonymous about 6 years ago

Bug fixed in LCMS 4.

Also available in: Atom PDF