Project

General

Profile

Support #5015

Problems ((certificate_barcode)) QR Code - Chamilo 1.8.8.4 / Chamilo 1.9

Added by Ricel Leite about 7 years ago. Updated almost 7 years ago.

Status:
Bug resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
19/06/2012
Due date:
% Done:

100%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Hello,

I would like to congratulate the whole team. This is the first time you report a problem with my installation Chamilo.
I'm having trouble with the generation of bar code to validate the certificate. By placing the tag ((certificate_barcode)) my certificate in the barcode does not appear, only the tag mentioned above.
I would like to know how to fix this problem on my installation.

Thank you and congratulations to everyone again.


Files

ScreenHunter_05_Jun._19_08.44.gif (1.38 KB) ScreenHunter_05_Jun._19_08.44.gif tag reference Ricel Leite, 19/06/2012 13:51
ScreenHunter_06_Jun._19_08.45.gif (9.05 KB) ScreenHunter_06_Jun._19_08.45.gif View the certificate by the student. Ricel Leite, 19/06/2012 13:51
ScreenHunter_07_Jun._19_08.45.gif (31.5 KB) ScreenHunter_07_Jun._19_08.45.gif Inserting the tag Ricel Leite, 19/06/2012 13:51
ScreenHunter_01_2012-07-24_12.24.jpg (20.4 KB) ScreenHunter_01_2012-07-24_12.24.jpg Ricel Leite, 24/07/2012 17:25
info.php (17 Bytes) info.php Yannick Warnier, 24/07/2012 18:32
phpinfo__.pdf (675 KB) phpinfo__.pdf Ricel Leite, 24/07/2012 18:48

Associated revisions

Revision a9b188cf (diff)
Added by Julio Montoya almost 7 years ago

Teacher can preview the qr code see #5015

History

#1

Updated by Yannick Warnier about 7 years ago

  • Target version changed from 1.9 Beta to 1.9 RC1
#2

Updated by Julio Montoya about 7 years ago

  • Status changed from New to Needs more info
  • Assignee deleted (Julio Montoya)

Hello Ricel,

It seems to work well for me, can you check if you have something in the apache error logs?

#3

Updated by Yannick Warnier about 7 years ago

Hola Ricel,

Por favor asegúrate que el ((certificate_barcode)) no sea algo transformado en el código, con el icono "Fuente HTML". Debe aparece igual en la fuente HTML que en el visualizador normal.

El código barra solo se cambiará cuando el alumno haya "ganado" el certificado.
Por favor revisa el manual de profesor de Chamilo 1.8.8.4 para estar seguro que no olvidaste algo.

#4

Updated by Yannick Warnier about 7 years ago

  • Target version changed from 1.9 RC1 to 1.9 Stable
#5

Updated by Yannick Warnier almost 7 years ago

  • Status changed from Needs more info to Rejected - Abandoned
#6

Updated by Ricel Leite almost 7 years ago

Hello,

The following tags work for me:

((user_firstname))
((user_lastname))
((gradebook_institution))
((gradebook_sitename))
((teacher_firstname))
((teacher_lastname))
((official_code))
((date_certificate))
((course_code))
((course_title))
((gradebook_grade))
((certificate_link))
((certificate_link_html))

Only the tag ((certificate_barcode)) does not work for me. See the attached image.

What can I do to test better?

Thank you.

#7

Updated by Ricel Leite almost 7 years ago

Hello Yannick and Julius.

I have a test environment. If you can help me, I can pass a username and password so you can test the inclusion of the certificate by using the tag ((certificate_barcode)) therefore need to validate certificates from users.

Thank you!

#8

Updated by Yannick Warnier almost 7 years ago

  • File info.php info.php added
  • Status changed from Rejected - Abandoned to Needs more info

Hi Ricel,

I think the problem is you don't have the libraries required to print the barcode, that's the only thing that pops to mind. Do you have access to a "phpinfo" page for your installation? Basically, it's as simple as putting the attached file in the Chamilo root directory and sending us the URL or the result of the page (save page as HTML and attach it here).

We need it to see which packages are installed on your server.

#9

Updated by Ricel Leite almost 7 years ago

Hello Yannick,

File with the following information from my test server

Thank you.

#10

Updated by Yannick Warnier almost 7 years ago

  • Target version changed from 1.9 Stable to 1.9.2

Hi Ricel,

You seem to have all the required elements to be able to generate a QR code. I don't see why they wouldn't be generated. Is your archive/ directory writeable? (I think QR images are temporarily stored there)

I'll have to move this task to our next stable version (1.9.2) for now. If we manage to find a solution, good, but otherwise I cannot let this individual problem get in the way of releasing 1.9. Sorry about that. That doesn't mean we will forget about it, but we have to get more information somehow. Maybe installing and enabling php5-xdebug would provide more details as to why it is failing...

Ultimately, you can always contact the Chamilo official providers for (commercial) help if this is really urgent.

#11

Updated by Ricel Leite almost 7 years ago

Hello Yannick,

Thanks for the help and I'll be waiting for a solution to this problem. I believe this functionality is an important item and super current (QR codes are widely used).

Thank you again.

#12

Updated by Ricel Leite almost 7 years ago

Hi Yannick,

It would be possible to create a virtual machine with Chamilo 1.8.8.4 or 1.9.2 to verify and test the functionality? That would be very important so I can more clearly understand the problems as the generation of the certificate among others.

Thank you again.

#13

Updated by Yannick Warnier almost 7 years ago

I wasn't referring to the features itself, but rather the fact that, in most cases, it works (and that the case you report is a bug we want to fix, but that we cannot reproduce it until now).

#14

Updated by Yannick Warnier almost 7 years ago

Sure, we could do that. You'll have to wait until after the 1.9 stable release though, because right now the agenda is rather intensely filled.

#15

Updated by Ricel Leite almost 7 years ago

Hi Yannick,

I am very grateful for the support and care quickly.

Congratulations and I'll be waiting!

Thank you!

#16

Updated by Ricel Leite almost 7 years ago

Hi Yannick,

The problem is solved, however, the QR code is generated only to a student. The administrator can not view the certificate with the barcode.

Many thanks and apologies for the delay in responding.

#17

Updated by Julio Montoya almost 7 years ago

  • Status changed from Needs more info to Assigned
  • Assignee set to Julio Montoya

I suppose you mean when you click the preview button? If that's true, I found the bug and I will fix it

#18

Updated by Julio Montoya almost 7 years ago

  • Status changed from Assigned to Needs testing
  • Assignee deleted (Julio Montoya)
  • % Done changed from 0 to 50

I sent a fix for that

#19

Updated by Julio Montoya almost 7 years ago

  • Assignee set to Yoselyn Castillo
#20

Updated by Ricel Leite almost 7 years ago

Thanks Julio!

You are doing a wonderful job. Congratulations!

#21

Updated by Yoselyn Castillo almost 7 years ago

  • Assignee deleted (Yoselyn Castillo)
#22

Updated by Julio Montoya almost 7 years ago

  • Status changed from Needs testing to Bug resolved
  • % Done changed from 50 to 100

Also available in: Atom PDF