Project

General

Profile

Bug #4840

BigBlueButton bug in 1.9 nightly 2012-06-04

Added by Jose Manuel Abuin Mosquera over 7 years ago. Updated about 7 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
-
Category:
Plugins
Target version:
Start date:
05/06/2012
Due date:
% Done:

100%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Hi all,

maybe this bug is already reported, I didn't find it.

I am using 1.9 nightly 2012-06-04 and BigBlueButton 0.8

In the BigBlueButton plugin code it's needed to add the protocol in the file plugin/bbb/lib/bbb.lib.php

Line: return BigBlueButtonBN::isServerRunning($this->url);

Should be: return BigBlueButtonBN::isServerRunning($this->protocol.$this->url);

If not, message, "Server is not running" appears.

I hope this helps :)


Related issues

Related to Chamilo LMS - Bug #5312: Problemas com BBB plugin on Chamilo 1.9 Stable.Bug resolved15/08/2012

Actions

Associated revisions

Revision 415612e5 (diff)
Added by Julio Montoya over 7 years ago

Improving bbb in order to create easily course plugins see #4840

Revision b8c4e549 (diff)
Added by Julio Montoya over 7 years ago

More corrections in the bbb plugin see #4840

History

#1

Updated by José Angel Ruiz (Nosolored) over 7 years ago

Buenos días,

para ampliar más información respecto a este tema, indicaré la batería de pruebas que he realizado por si sirve de algo.

Antes de ver la solución propuesta por Jose Manuel Abuin, lo que hice fué lo siguiente:

1º En la configuración de plugin de bbb en la casilla de BigBlueButton host puse la IP de la siguiente manera.
http://<ip>

2º En el archivo plugin/bbb/lib/bbb.lib.php la línea: var $protocol = 'http://'; la sustituyo por: var $protocol = '';
De esta forma entra correctamente.

Probando la solución propuesta por Jose Manuel Abuin, deja de aparecer el mensaje de "Server is not running", pero luego me sucede que cuando hago clic al botón de "Enter to the videoconference" se abre una nueva página indicando servidor no encontrado y la url asociada es 'unable to fetch url &checksum=e445a427d0544f23a03971349e3a6f2ff93f0a70', cierro esta página para volver a la página de "Record list", actualizo y aparece que hay una "meeting opened", cuando vuelvo a darle al botón de "Enter to the videoconference" me sale la siguiente información:

url: http://192.168.1.34/bigbluebutton/api/join?meetingID=65&fullName=Ruiz%2C+Jose+Angel&password=CURSOADMINmod&checksum=ba4f4f321c0c082e55fa56973041ad2eb83ceddc

contenido:
Este fichero XML no parece tener ninguna información de estilo asociada. Se muestra debajo el árbol del documento.
<response><returncode>FAILED</returncode><messageKey>invalidMeetingIdentifier</messageKey><message>The meeting ID that you supplied did not match any existing meetings</message></response>

Aporto datos de plataforma y sistema.
Equipo: linux Ubunto 10.04
Videoconferencia BigBlueButton 0.8
Chamilo chamilo-1.9.0-alpha10

Espero que sea de utilidad.
Un saludo a la comunidad Chamilo.

#2

Updated by Julio Montoya over 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Julio Montoya
#3

Updated by Julio Montoya over 7 years ago

  • Status changed from Assigned to Needs more info
  • Assignee deleted (Julio Montoya)
  • % Done changed from 0 to 40

Hola, gracias por reportar los errores,
he agregado varios arreglos, recomiendo desinstalar y volver a instalar el plugin (recuperar código del repositorio ) o esperar el nightly build de hoy 2012-06-0

#4

Updated by Jose Manuel Abuin Mosquera over 7 years ago

I'll try it tomorrow with today's nightly build :)

#5

Updated by Julio Montoya over 7 years ago

  • % Done changed from 40 to 80

Parece que todo va bien con esta tarea, considerar cerrarla

#6

Updated by Yannick Warnier over 7 years ago

  • Target version changed from 1.9 Stable to 1.9 RC1
#7

Updated by Jose Manuel Abuin Mosquera over 7 years ago

Hola, perdonad el retraso en contestar aqui

En efecto, está funcionando bien :)

Lo que sí he detectado es que dependiendo de la vista elegida para el curso, el icono de BigBlueButton no aparece en el curso, intentaré proporcionar más feedback en cuanto pueda

Un saludo

#8

Updated by Yannick Warnier over 7 years ago

  • Status changed from Needs more info to Bug resolved
  • Assignee set to Julio Montoya
  • % Done changed from 80 to 100

OK, esto ya puede ir en otra tarea, cuando puedas. Gracias!

#9

Updated by Ricel Leite over 7 years ago

Hello,

I installed the stable version 1.9 and the problems still persist with the BBB. How to solve these problems?

#10

Updated by Ricel Leite over 7 years ago

Hello,

Just to remember, I upgraded to version 1.8.8.4 to 1.9 and the problems persist.

Thank you.

#11

Updated by Yannick Warnier over 7 years ago

  • Status changed from Bug resolved to Assigned
  • Target version changed from 1.9 RC1 to 1.9.2
#12

Updated by Julio Montoya about 7 years ago

  • Status changed from Assigned to New
  • Assignee deleted (Julio Montoya)
#13

Updated by Julio Montoya about 7 years ago

  • Status changed from New to Bug resolved
  • Target version changed from 1.9.2 to 1.9.4

this issued seems to be already fixed closing and moving to 1.9.4. If the error persists feel free to reopen the task

#14

Updated by Yannick Warnier about 7 years ago

  • Category set to Plugins
  • Target version changed from 1.9.4 to 1.9.2

If you consider it fixed, I prefer having it set to 1.9.2, so that I can properly include it in the Changelog.

Also available in: Atom PDF