Project

General

Profile

Bug #4807

Style broken on homepage - anonymous

Added by Yannick Warnier over 7 years ago. Updated over 7 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
27/05/2012
Due date:
% Done:

100%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

I'm not sure what the goal is for the new style, but currently you have to jump back and forth to find the login box. This is really not a good idea to make it attractive for new users.


Files

no_login.png (70.7 KB) no_login.png Julio Montoya, 28/05/2012 12:04

Associated revisions

Revision 74054415 (diff)
Added by Julio Montoya over 7 years ago

Fixing wrong subnav CSS attributes see #4807

Revision e46b7930 (diff)
Added by Julio Montoya over 7 years ago

Hiding breadcrumb when there are no link, showing always the blue bar see #4807

Revision a1532c34 (diff)
Added by Julio Montoya over 7 years ago

Adding blue bar during the installation process see #4807

History

#1

Updated by Julio Montoya over 7 years ago

you mean this? I have to scroll to login?
This is a bug because of the tabs, fixing ...

#2

Updated by Julio Montoya over 7 years ago

  • Status changed from Assigned to Needs more info
  • Assignee changed from Julio Montoya to Yannick Warnier
  • % Done changed from 10 to 80

chamilodev was reinstalled and the table now exists this comment doesn't belong to this task sorry

#3

Updated by Julio Montoya over 7 years ago

This was caused due an old CSS should be fixed now

#4

Updated by Marko Kastelic over 7 years ago

Noticed before that this was visible only with english home. If you choose another language thereis stil no main portal menu.

#5

Updated by Yannick Warnier over 7 years ago

  • Assignee changed from Yannick Warnier to Julio Montoya

Mmm... not sure what is the expected view, but here I have installed a 1.9 hg from scratch and I have no blue tabs. Is that "normal" or...? What is the expected style when the portal works as normal? Your screenshot?

#6

Updated by Julio Montoya over 7 years ago

  • Assignee changed from Julio Montoya to Yannick Warnier

Yannick Warnier wrote:

Mmm... not sure what is the expected view, but here I have installed a 1.9 hg from scratch and I have no blue tabs. Is that "normal" or...? What is the expected style when the portal works as normal? Your screenshot?

Current status:

blue tabs will be available only if you added pages in main/admin/configure_homepage.php (add page CMS)

otherwise no reason to add the blue tab.


I could be a good idea to show the blue bar with only 1 link "Homepage"?

what do you think?

#7

Updated by Yannick Warnier over 7 years ago

  • Status changed from Needs more info to Assigned
  • Assignee changed from Yannick Warnier to Julio Montoya

I think it's confusing to have the blue bar sometimes and sometimes not, depending on whether there is something in it or not. The idea in terms of usability is that everything that is not stable is a source of stress, so making a bar "appear" after it was hidden is stressfull.

But indeed, if all that's needed is a "homepage" page, I think it would be good to offer this page by default on Chamilo installation, so that they have the blue bar. If they want to remove it, they can, but I really think it is confusing to have the main navigation bar disappear like this.

Could you please make sure there is either the classic "Home" page (the one that used to appear in previous versions)? I think the rest of the interface changes are already enough for old-time users. We want to make progressive changes. We have had a large number of users coming to us because they got confused by the massive style change in D0keos. I wouldn't want that to happen to us now :-)

#8

Updated by Yannick Warnier over 7 years ago

I agree that the (grey) breadcrumb section can disappear from time to time if it doesn't contain anything, because it is usually very discrete (almost invisible background in contrast with the rest), but the blue should remain.

#9

Updated by Julio Montoya over 7 years ago

The blue bar is always show, to change the label just change "Homepage" to "home" in translate.chamilo.org

#10

Updated by Julio Montoya over 7 years ago

  • Status changed from Assigned to Needs more info
  • Assignee changed from Julio Montoya to Yannick Warnier
#11

Updated by Yannick Warnier over 7 years ago

  • Status changed from Needs more info to Bug resolved
  • Assignee changed from Yannick Warnier to Julio Montoya
  • % Done changed from 80 to 100

It's ok for me now (the content of the homepage is a bit too close from the blue bar, but it can be fixed by adding a blank line in the editor). Thanks.

Also available in: Atom PDF