Project

General

Profile

Bug #4805

Database c_* error in forum

Added by Yannick Warnier over 7 years ago. Updated over 7 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
27/05/2012
Due date:
% Done:

100%

Estimated time:
0.25 h
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Surprisingly, this happened in the learning path tool for me (in test server mode) while trying to add a multimedia page (before selecting which type of object I wanted - between docs, exercises, etc)

DATABASE ERROR #1146:
Table 'chamilo.c_forum_notification' doesn't exist
QUERY :
SELECT * FROM `chamilo`.`c_forum_notification` WHERE c_id = 1 AND user_id='1'
FILE :
/var/www/chamilo/main/forum/forumfunction.inc.php
LINE :
4012
FUNCTION :
get_notifications_of_user

Occured on a Chamilo 1.9 dev installed today.


Files

ch19-lp-forum-c_id.png (82.7 KB) ch19-lp-forum-c_id.png Yannick Warnier, 27/05/2012 06:12

Associated revisions

Revision f184950c (diff)
Added by Julio Montoya over 7 years ago

Should fix table creation see #4805

History

#1

Updated by Yannick Warnier over 7 years ago

Also occured while trying to create a new evaluation component in the gradebook (where there is a list of resource types...). Exactly the same message.

#2

Updated by Yannick Warnier over 7 years ago

Also occured in new forum category creation (http://my.chamilo.net/main/forum/index.php?cidReq=VVCVC&id_session=0&gidReq=0&gradebook=&action=add&content=forumcategory&lp_id=). Exact same error message.
I know once fixed, it should be fixed everywhere, but I want to make sure when fixed it doesn't create another error message in any of those places.

#3

Updated by Yannick Warnier over 7 years ago

Also happens when entering a group page (of an existing group) inside a course and in all the forum section inside that area.

#4

Updated by Yannick Warnier over 7 years ago

This might help: in some cases, when creating a forum thread, I get this additional error message (on top of the one quoted here):

DATABASE ERROR #1064:
 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND tool='forum_thread' AND ref='1'' at line 3
QUERY       :
 UPDATE `chamilo`.`c_item_property`
                    SET lastedit_date='2012-05-27 16:18:29', lastedit_user_id='1' , lastedit_type='ForumThreadAdded' 
                    WHERE  c_id =  AND tool='forum_thread' AND ref='1'  
FILE        :
 /var/www/chamilo/main/inc/lib/main_api.lib.php
LINE        :
 2979
FUNCTION    :
 api_item_property_update

#5

Updated by Julio Montoya over 7 years ago

for some reasong the table c_forum_notification doesn't exist in chamilodev I'm going to reinstall chamilodev

#6

Updated by Julio Montoya over 7 years ago

  • Status changed from Assigned to Needs more info
  • Assignee deleted (Julio Montoya)
  • % Done changed from 0 to 80

the table was not correctly created should be fixed

#7

Updated by Julio Montoya over 7 years ago

  • Assignee set to Yannick Warnier

chamilodev was reinstalled and the table now exists

#8

Updated by Yannick Warnier over 7 years ago

  • Status changed from Needs more info to Bug resolved
  • Assignee changed from Yannick Warnier to Julio Montoya
  • % Done changed from 80 to 100

Fixed. Thanks.

Also available in: Atom PDF