Project

General

Profile

Bug #4790

Chamilo-1.9.0.alpha6

Added by Eric Petitdemange over 7 years ago. Updated over 7 years ago.

Status:
Feature implemented
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
23/05/2012
Due date:
% Done:

100%

Estimated time:
1.00 h
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Hi all,

I'm not sure if a 7 is on the starting blocks, but I've got an issue with alpha6.
I downloaded the zip file, but the file is 57.4 MB instead of 57.5 given on the site.
Decompressing OK => 107 MB folder.
When trying to install, you are able to select the language, then click on "Next" and the page stays blank. The step 2 doesn't show up...
Tha only "message" we can see is in address bar: http://127.0.0.1/chamilo19a6/main/install/index.php?running=1&installType=&updateFromConfigFile=
As you can see I avoid any issue of resources as I try a local install.

FYI the test was done on 2 different computers and the same issue araise.

Thanks in advance for your help.

Associated revisions

Revision b358024b (diff)
Added by Julio Montoya over 7 years ago

Changing REQUIRED_PHP_VERSION to version 5.3 see #4790

History

#1

Updated by Julio Montoya over 7 years ago

a new alpha 7 is coming today with more fixes due the recent changes in the Session class

#2

Updated by Eric Petitdemange over 7 years ago

  • Status changed from New to Bug resolved

Ok, Thkx Julio, I put this one as resolved..

I'm looking forward to having a try on the a7....

#3

Updated by Yannick Warnier over 7 years ago

  • Status changed from Bug resolved to Assigned
  • Assignee set to Julio Montoya
  • Target version set to 1.9 Beta
  • % Done changed from 0 to 10
  • Estimated time set to 1.00 h

Also, you now need PHP 5.3 to install Chamilo. This is a requirement we cannot avoid, due to the usage of the new templating system (Twig, from Symfony 2).

Julio, there should be a warning on the first page of Chamilo installation screen if PHP 5.3 is not installed. This is the only place where we can warn the user. Message (if php_version() < 5.3):

$InstallWarningPHP53Missing = "Warning: we have detected that your version of PHP is 5.2 or inferior. To install Chamilo 1.9, you need to have PHP 5.3 or superior installed. PHP 5.3 was officially released in June 2009, so it is very stable, and installing it or any superior version of PHP will also benefit your server in terms of security and efficiency.
If you don't know what we're talking about, please contact your hosting provider or your support team.
If you decide to ignore this message and continue to the installation process, you might see error messages or a blank page, depending on your configuration, but you will not be able to install Chamilo.";

I think the "Install Chamilo" button should be disabled in this case, and this message should not appear as aggressive (many people might feel deeply worried about it, so we have to take them kindly).

Also, the translation on this page should be available through the language selection bar (I think there is an automatic language detector but I'm not sure it's on this page).

#4

Updated by Eric Petitdemange over 7 years ago

Good to know this one, I'm confident as using 5.3.8 and Apache 2.21 (Wamp server 2.2).
But I'll have to check on my production portal (I think tis is OK also, but double checking is good to have).

BTW if you need a hand to translate Yannick's text, I can help ;)

#5

Updated by Julio Montoya over 7 years ago

Those messages already exists but only in english, the traduction system can't work if you don't have the mininum PHP requeriments. I'm changing the constant "REQUIRED_PHP_VERSION" to 5.3 and tuning a little bit the main/inc/global_error_message.inc.php where those messages are set

Yannick Warnier wrote:

Also, you now need PHP 5.3 to install Chamilo. This is a requirement we cannot avoid, due to the usage of the new templating system (Twig, from Symfony 2).

Julio, there should be a warning on the first page of Chamilo installation screen if PHP 5.3 is not installed. This is the only place where we can warn the user. Message (if php_version() < 5.3):

$InstallWarningPHP53Missing = "Warning: we have detected that your version of PHP is 5.2 or inferior. To install Chamilo 1.9, you need to have PHP 5.3 or superior installed. PHP 5.3 was officially released in June 2009, so it is very stable, and installing it or any superior version of PHP will also benefit your server in terms of security and efficiency.
If you don't know what we're talking about, please contact your hosting provider or your support team.
If you decide to ignore this message and continue to the installation process, you might see error messages or a blank page, depending on your configuration, but you will not be able to install Chamilo.";

I think the "Install Chamilo" button should be disabled in this case, and this message should not appear as aggressive (many people might feel deeply worried about it, so we have to take them kindly).

Also, the translation on this page should be available through the language selection bar (I think there is an automatic language detector but I'm not sure it's on this page).

#6

Updated by Julio Montoya over 7 years ago

  • Status changed from Assigned to Needs more info
  • Assignee deleted (Julio Montoya)
  • % Done changed from 10 to 80

alpha 8 should be released soon with these changes

#7

Updated by Julio Montoya over 7 years ago

  • Status changed from Needs more info to Feature implemented
  • % Done changed from 80 to 100

Also available in: Atom PDF