Project

General

Profile

Bug #4600

base css loaded after them CSS

Added by Laurent Opprecht over 7 years ago. Updated over 7 years ago.

Status:
Rejected - Abandoned
Priority:
Normal
Category:
-
Target version:
Start date:
10/04/2012
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Looks like a few base css:

boostrap, base_chamilo, etc

are loaded after the theme css. Which makes difficult for the theme to overwrite them rules - unless you resolve to using !important statements which you shoud avoid.

Could we have that the other way around? That is to load the theme css in the end.

History

#1

Updated by Yannick Warnier over 7 years ago

I have already discussed this in the past with Julio and I am surprised this is still the case. It should, by no account, be last in the CSS order. These base styles are to be used to give a base style and then be overwritten by specific styles.

#2

Updated by Julio Montoya over 7 years ago

  • Status changed from New to Needs more info
  • Assignee changed from Julio Montoya to Laurent Opprecht

Yannick Warnier wrote:

I have already discussed this in the past with Julio and I am surprised this is still the case. It should, by no account, be last in the CSS order. These base styles are to be used to give a base style and then be overwritten by specific styles.

I just checked out and this is the current order:


<style type="text/css" media="screen">
/*<![CDATA[*/
@import "http://my.chamilo.net/main/css/base.css";
@import "http://my.chamilo.net/main/css/chamilo/default.css";
@import "http://my.chamilo.net/main/css/chamilo/course.css";
@import "http://my.chamilo.net/main/css/bootstrap-responsive.css";
@import "http://my.chamilo.net/main/css/responsive.css";
/*]]>*/
</style>

Inside base.css there's a call to bootstrap.css
Inside default.css we have a call to base_chamilo.css

The bootstrap-responsive.css and responsive.css are only "on" when we change the size of the window using @media tags
Maybe you see that behavior in another page?

#3

Updated by Laurent Opprecht over 7 years ago

I think I got confused by bootstrap as I am not able to reproduce. Just some jquery css being loaded after but that's not much of an issue.

Will let you know if I find something.

#4

Updated by Yannick Warnier over 7 years ago

  • Status changed from Needs more info to Rejected - Abandoned
  • Target version set to 1.9 Beta
  • % Done changed from 0 to 100

Good (sorry for doubting you Julio). I'm closing the task. Feel free to re-open if you find anything.

Also available in: Atom PDF