Project

General

Profile

Bug #4493

Some bugs in exercices - Chrome + audio

Added by Juan Carlos Raña Trabado over 7 years ago. Updated about 7 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
17/03/2012
Due date:
% Done:

100%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

1. when select a category
Fatal error: Cannot redeclare showQuestion() (previously declared in C:\xampp\htdocs\chamilo190\main\exercice\exercise.lib.php:39) in C:\xampp\htdocs\chamilo190\main\exercice\exercise.lib.php on line 703

2. audio exdercices doesnt run


Files

nanogong-exe.png (11.6 KB) nanogong-exe.png Yannick Warnier, 19/07/2012 19:08

Related issues

Related to Chamilo LMS - Bug #4788: nanogong files don't play into document toolBug resolved21/05/2012

Actions

Associated revisions

Revision 8ca9717b (diff)
Added by Julio Montoya over 7 years ago

Fixing fatal error "showquestion redeclare" see #4493

Revision 443f8084 (diff)
Added by Julio Montoya about 7 years ago

Showing simple form if nanogong doesn't load well see #4493

Revision 732aed1c (diff)
Added by Julio Montoya about 7 years ago

Showing simple form if nanogong doesn't load see #4493

Revision 6b10f4b1 (diff)
Added by Julio Montoya about 7 years ago

Adding link to show a form to upload a file see #4493

Revision 46f7ffab (diff)
Added by Julio Montoya about 7 years ago

Showing link to upload file and nanogong form see #4493

History

#1

Updated by Julio Montoya over 7 years ago

  • Status changed from New to Needs more info
  • % Done changed from 0 to 30

1. I confirmed the bug it should be fixed with

http://code.google.com/p/chamilo/source/detail?r=e19c4b65440ecd04f4df69fab330da2cb8217203&repo=classic

2. need more info in order to debug the error, browser version, OS

#2

Updated by Juan Carlos Raña Trabado over 7 years ago

Julio Montoya wrote:

1. I confirmed the bug it should be fixed with

http://code.google.com/p/chamilo/source/detail?r=e19c4b65440ecd04f4df69fab330da2cb8217203&repo=classic

2. need more info in order to debug the error, browser version, OS

Con Chrome 17.0.963.79 sobre OSX10.6.8 no se carga cuando se intenta visualizar la pantallita que carga el applet quedándose en blanco
Con Safari y Firefox va bien

#3

Updated by Yannick Warnier over 7 years ago

  • Target version changed from 1.9 Stable to 1.9 Beta
#4

Updated by Yannick Warnier over 7 years ago

  • Subject changed from some bug in exercices to Some bugs in exercices - Chrome + audio
  • Target version changed from 1.9 Beta to 1.9 RC1
#5

Updated by Yannick Warnier about 7 years ago

On Ubuntu 12.04 and Chromium 18, it tells me my java is not up to date (I have Sun Java 6.26 library with sun-java6-plugin installed, but apparently that isn't recognized by chromium)

#6

Updated by Yannick Warnier about 7 years ago

In Firefox 13.0.1 on the same computer, my browser crashed when clicking the "Record answer" button and loading the applet (the modal window appears, but the browser crashes while loading the java applet).

#8

Updated by Julio Montoya about 7 years ago

  • Status changed from Needs more info to Assigned
  • Assignee set to Yoselyn Castillo

need to be tested

#9

Updated by Yoselyn Castillo about 7 years ago

  • Status changed from Assigned to Needs more info
  • Assignee changed from Yoselyn Castillo to Juan Carlos Raña Trabado
  • % Done changed from 30 to 90

Questions categories don't have any problem
Audio exercises work perfectly for me in Chrome and Firefox.
It seems to be fixed. Please confirm it for closing the task

#11

Updated by Juan Carlos Raña Trabado about 7 years ago

  • Status changed from Needs more info to Feature implemented
#12

Updated by Yannick Warnier about 7 years ago

  • Status changed from Feature implemented to Assigned
  • Assignee changed from Juan Carlos Raña Trabado to Julio Montoya
  • % Done changed from 90 to 70

Sorry, can't close just yet. On Ubuntu + Chromium 18, when the plugin error appears, clicking the "Send record" button, I cannot send any audio. I think the intention is to make it possible to send an audio recording manually, right?

#13

Updated by Yannick Warnier about 7 years ago

Yannick Warnier wrote:

Sorry, can't close just yet. On Ubuntu + Chromium 18, when the plugin error appears, clicking the "Send record" button, I cannot send any audio. I think the intention is to make it possible to send an audio recording manually, right?

OK, I'm confused now. In Ubuntu + Firefox, the Java recording works, but I thought (Julio) that there was an option to send an audio file, wasn't there?

#14

Updated by Julio Montoya about 7 years ago

  • Status changed from Assigned to Needs more info
  • Assignee deleted (Julio Montoya)

Yannick Warnier wrote:

Yannick Warnier wrote:

Sorry, can't close just yet. On Ubuntu + Chromium 18, when the plugin error appears, clicking the "Send record" button, I cannot send any audio. I think the intention is to make it possible to send an audio recording manually, right?

OK, I'm confused now. In Ubuntu + Firefox, the Java recording works, but I thought (Julio) that there was an option to send an audio file, wasn't there?

well, normally if the applet is not load then you should have a warning message and a simple form to send a file I sent a fix

#15

Updated by Yannick Warnier about 7 years ago

In Chromium it seems like the "plugin not present" does not work (it says the plugin is present but outdated).

Would it be possible to show an "unfoldable" area that allows you to upload the audio by hand anyway (even if the recorder works)?

Something like the attached image (and then only an upload area would appear).

#16

Updated by Juan Carlos Raña Trabado about 7 years ago

Disculpas por cerrar antes de tiempo la tarea, aunque en su momento funcionaba.
Ahora además he visto que hay más problemas en la herramienta ejercicios y no solo con Chrome, también con Firefox por ejemplo cuando intento editar un ejercicio todos los iconos de tipo de pregunta aparecen en gris, incluso dos el de ejercicios de audio y el global de respuestas múltiples no cargan el icono.
Otro problema es que cuando intento crear un ejercicio nuevo y añadir una pregunta han desaparecido los botones de aceptar en la parte inferior con lo que no se puede guardar

#17

Updated by Juan Carlos Raña Trabado about 7 years ago

No sé si hay más bugs, pero deben haber sido introducidos hace poco...

#18

Updated by Julio Montoya about 7 years ago

ok ahora aplico lo que Yannick menciona, voy a ver el tema tambien que comenta Juan Carlos, supongo que es por el último fix de seguridad que se aplicó en la rama

#19

Updated by Julio Montoya about 7 years ago

  • Status changed from Needs more info to Assigned
  • Assignee set to Julio Montoya
#20

Updated by Julio Montoya about 7 years ago

  • Status changed from Assigned to Needs more info
  • Assignee deleted (Julio Montoya)

enlace agregado, no he visto el problema que menciona Juan Carlos, tal vez ya fue solucionado?

#21

Updated by Yannick Warnier about 7 years ago

  • Assignee set to Julio Montoya

It's better this way. Julio, it is a problem showing both options at the same time? Currently, if I click on the link, th only way to try again the audio recorder is to close the window and click the "Record audio" button again. I think the part above the link shouldn't disappear. The link should just extend in the area below (which is large enough to actually show the upload form without extension)

#22

Updated by Juan Carlos Raña Trabado about 7 years ago

Julio A. Montoya wrote:

enlace agregado, no he visto el problema que menciona Juan Carlos, tal vez ya fue solucionado?

at the moment run well

#23

Updated by Julio Montoya about 7 years ago

  • Assignee deleted (Julio Montoya)

Yannick Warnier wrote:

It's better this way. Julio, it is a problem showing both options at the same time? Currently, if I click on the link, th only way to try again the audio recorder is to close the window and click the "Record audio" button again. I think the part above the link shouldn't disappear. The link should just extend in the area below (which is large enough to actually show the upload form without extension)

coded added to showing the link and the nanogong form, no problem showing both forms

#24

Updated by Yannick Warnier about 7 years ago

  • Status changed from Needs more info to Bug resolved
  • Assignee set to Julio Montoya
  • % Done changed from 70 to 100

Good for me now. Closing...

Also available in: Atom PDF