Project

General

Profile

Feature #4465

Chamilo 1.9 acceso con ssl (https://)

Added by Jose García (Nosolored) over 7 years ago. Updated about 7 years ago.

Status:
Bug resolved
Priority:
Normal
Category:
-
Target version:
Start date:
09/03/2012
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Buenos días.

Un usuario en el foro http://www.chamilo.org/forum/viewtopic.php?f=15&t=1901 comenta que usa Chamilo con certificado ssl (https://) comenta que no se visualizan las imágenes dentro de Chamilo al ser diferente la ruta.

¿Habéis comprobado el uso del aula con una configuración con ssl tal como https://micampus.com? ¿Está preparado Chamilo para usar certificados ssl?

Un saludo.

Jose García
Nosolored

History

#1

Updated by Julio Montoya over 7 years ago

  • Status changed from New to Needs more info
  • % Done changed from 0 to 30

Este bug ya ha sido reportado si mal no recuerdo y me parece que ya esta corregido con chamilo 1.9 habría que probarlo.

http://code.google.com/p/chamilo/source/detail?r=2b5e0e7024e1f76663c6d2b98b0b0d13d73bf6a3&repo=classic

#2

Updated by Yannick Warnier over 7 years ago

  • Target version changed from 1.9 Stable to 1.9 Beta
#3

Updated by Yannick Warnier over 7 years ago

Arnaud, Noël, we need someone to check that the SSL works well with Chamilo 1.9 alpha. I know you've written some patches in the past for that, and in this case we have added some for the FCKeditor. Is it easy for you to have a quick look around and give us your confirmation that it works?

Please test with an upstream version (from Google Code)

#4

Updated by Yannick Warnier over 7 years ago

  • Target version changed from 1.9 Beta to 1.9 RC1
#5

Updated by Yannick Warnier about 7 years ago

Pinging Arnaud and Noël again...

#6

Updated by Yannick Warnier about 7 years ago

  • Status changed from Needs more info to Feature implemented

Closing for lack of feedback.

#7

Updated by Yannick Warnier about 7 years ago

  • Status changed from Feature implemented to Assigned
  • Assignee set to Noël Dieschburg
#8

Updated by Yannick Warnier about 7 years ago

  • Target version changed from 1.9 RC1 to 1.9 Stable
#9

Updated by Noël Dieschburg about 7 years ago

  • % Done changed from 30 to 100

Acabo de comprobar installando un trunk de chamilo en https solo. Y no he visto ningun problemas.

Todo funciona bien. Cada imagen se carga bien en https. Y todo funciona

He comprobado unas cuantas paginas pero no todas claro. Pero me quedo este chamilo para mi desarollo. Entonces si hay problemas mas escondido ya lo vere.

Lo que puede ser tambien es que el hombre del forum se ha copiado curso desde su antigua plateforma hasta la nueva. Y de lo que se yo, hay unos cuantos enlace completos en la basis de datos de los cursos. Lo que puede hace es modificar su archivo mysql con sed :

sed -i 's,http://urldelaplateforma,https://urldelaplateform,g' archivo.sql

Y despues importar de nuevo.

#10

Updated by Noël Dieschburg about 7 years ago

  • Status changed from Assigned to Bug resolved

Also available in: Atom PDF