Project

General

Profile

Bug #4405

Extraño error con el login (Chamilo 1.8.8.4)

Added by Laura Guirao over 7 years ago. Updated over 7 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
21/02/2012
Due date:
% Done:

100%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Publico esta nueva petición más bien con la intención de comprobar si a alguien más le ha ocurrido, por intentar averiguar si se trata de un fallo pues es algo bastante curioso.
Si se inserta en el texto de un anuncio un enlace a algún contenido interior del curso, como por ejemplo una lección o un documento, al hacer click el usuario que recibe el e-mail en el enlace, a veces, ocurre lo siguiente:
- Aparece la página del aula de Chamilo con el mensaje de que no estás logueado y los campos para acceder
- Introduces tus datos de acceso pero cuando le das a entrar no hace nada, y te los vuelve a pedir
- Si vuelves a introducirlos y pulsas de nuevo entrar, se va a una pantalla del curso diferente a la enlazada

Esto ha ocurrido un par de veces en Google Chrome y Mozilla Firefox.
Después de repetirlo varias veces, siempre sin estar logueado previamente en el aula, no siempre da este fallo, a veces funciona bien.
¿A alguien más le ha ocurrido?

Associated revisions

Revision 93c81487 (diff)
Added by Julio Montoya over 7 years ago

Should fix bug when redirecting the api_not_allowed() form to the wanted URL see #4405

History

#1

Updated by Yannick Warnier over 7 years ago

  • Target version set to 1.9 Beta
#2

Updated by Julio Montoya over 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Julio Montoya
#3

Updated by Yannick Warnier over 7 years ago

Hola Laura,

Bienvenida de vuelta.

En tu caso, el curso de destino es una copia de otro curso?

#4

Updated by Julio Montoya over 7 years ago

  • Status changed from Assigned to Needs more info
  • Assignee deleted (Julio Montoya)
  • % Done changed from 0 to 40

Acabo de enviar un parche para corregir la redirecciǿn de una URL (cuando aparece el mensaje de error con el formulario) a otra para chamilo 1.9, antes enviaba directamente a userportal.php ahora va hacia la URL requerida, necesita testing.

#5

Updated by Yannick Warnier over 7 years ago

  • Assignee set to Laura Guirao

Laura, podrías darle una revisada porfa?

#6

Updated by Yannick Warnier over 7 years ago

  • Status changed from Needs more info to Bug resolved
  • Assignee changed from Laura Guirao to Julio Montoya
  • % Done changed from 40 to 100

Para extender un poco (antes de cerrar esta tarea) sí, Laura, es normal, ciertas URLs tienen una mejor gestión de la redirección que otras. Depende de los scripts que hay por debajo, y la interfaz de respuesta todavía no es un gran controlador común, así que depende de cada herramienta...

Gracias por reportar. Estamos cerrándola porque nos urge cerrar la beta y que, de lo visto, esta tarea ya no es un problema.

Also available in: Atom PDF