Project

General

Profile

Bug #3922

Folders in Documents Tool not Visible for Anonymous User When Couse Access Set to Open

Added by Robert Parlett almost 9 years ago. Updated almost 8 years ago.

Status:
Bug resolved
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
Start date:
25/09/2011
Due date:
% Done:

100%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Upgraded system from 1.8.8.2 to 1.8.8.4. Now courses that are set to open access do not display any folders when Joe Anonymous user browses to the Documents tool.


Files

mod184_anonymous.zip (90.7 KB) mod184_anonymous.zip Andre Boivin, 18/10/2011 00:07

Related issues

Related to Chamilo LMS - Bug #3865: World-access on course does not work for DocumentsFeature implemented01/09/2011

Actions

History

#1

Updated by Julio Montoya over 8 years ago

  • Status changed from New to Needs more info
  • % Done changed from 0 to 20

I think this was already reported and fixed, it works well at least in Chamilo 1.9.

You can test it in chamilodev.beeznest.com

#2

Updated by Robert Parlett over 8 years ago

I can't test on chamilodev.beeznest.com because I can't get to the course access section in course settings. I'll download 1.9 and test on my own server and see if the issue is fixed.

#3

Updated by Andre Boivin over 8 years ago

  • Priority changed from Normal to Urgent

We are on version 1.8.8.4 and we need access in anonymous mode. What files are involved? We can not go to the version 1.9 now.

#5

Updated by Robert Parlett over 8 years ago

FYI I tested an upgrade from 1.8.8.4 to 1.9 code as of 10/15 and it seems to clear up this particular issue (although I found some other issues). I tried updating just the files from

http://code.google.com/p/chamilo/source/detail?r=3d504aaf6c908426c75e079e114d5472e236a4e7&repo=classic

on my 1.8.8.4 test server and regrettably that didn't work very well.

#6

Updated by Andre Boivin over 8 years ago

You can use my mod. files

#7

Updated by Julio Montoya over 8 years ago

Hello Robert, remember that the current code of Chamilo 1.9 is only for testing purposes, you can report any issues you found before we're releasing so we can fix it

Robert Parlett wrote:

FYI I tested an upgrade from 1.8.8.4 to 1.9 code as of 10/15 and it seems to clear up this particular issue (although I found some other issues). I tried updating just the files from

http://code.google.com/p/chamilo/source/detail?r=3d504aaf6c908426c75e079e114d5472e236a4e7&repo=classic

on my 1.8.8.4 test server and regrettably that didn't work very well.

#8

Updated by Robert Parlett over 8 years ago

Andre Boivin wrote:

You can use my mod. files

Tested and works great. Thanks.

#9

Updated by Robert Parlett over 8 years ago

Julio Montoya wrote:

Hello Robert, remember that the current code of Chamilo 1.9 is only for testing purposes, you can report any issues you found before we're releasing so we can fix it

Robert Parlett wrote:

FYI I tested an upgrade from 1.8.8.4 to 1.9 code as of 10/15 and it seems to clear up this particular issue (although I found some other issues). I tried updating just the files from

http://code.google.com/p/chamilo/source/detail?r=3d504aaf6c908426c75e079e114d5472e236a4e7&repo=classic

on my 1.8.8.4 test server and regrettably that didn't work very well.

OK. Shall I create new bug reports then?

#10

Updated by Julio Montoya over 8 years ago

Of course, you're welcome to do so!

Robert Parlett wrote:

OK. Shall I create new bug reports then?

#11

Updated by Yannick Warnier about 8 years ago

  • Target version set to 1.9 Beta
#12

Updated by Yannick Warnier about 8 years ago

  • Target version changed from 1.9 Beta to 1.9 RC1
#13

Updated by Yannick Warnier almost 8 years ago

  • Status changed from Needs more info to Bug resolved
  • % Done changed from 20 to 100

Patch has been approved by more than one user. Thanks.

Also available in: Atom PDF