Project

General

Profile

Bug #3919

Quiz - Image on zones with french accents

Added by Alain Deschênes almost 10 years ago. Updated almost 9 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
25/09/2011
Due date:
% Done:

80%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

I've got some problems with french accents on Image zones questions...

Get a look on attached file.

Thanks,

Alain


Files

test_on_image_with_french_accents.pdf (215 KB) test_on_image_with_french_accents.pdf Alain Deschênes, 25/09/2011 08:54
tech_cat.png (317 KB) tech_cat.png Julio Montoya, 15/10/2012 14:59
test_cat2.png (319 KB) test_cat2.png Julio Montoya, 15/10/2012 15:05

Associated revisions

Revision 507e9367 (diff)
Added by Julio Montoya almost 9 years ago

Adding security::remove_XSS see #3919

Revision 7cfd3da0 (diff)
Added by Julio Montoya almost 9 years ago

Adding security::remove_XSS see #3919

History

#1

Updated by Alain Deschênes almost 10 years ago

Just a word to say... I've found that bug on release 1.8.8.4 - and I can repeat that bug on http://campus.chamilo.org/.

#2

Updated by Olivier CORRE almost 10 years ago

I think this is a recurrent bug that was found before. I think it requires recompiling the flash module for this type of exercice.

#3

Updated by Julio Montoya almost 10 years ago

  • Status changed from New to Assigned
  • Assignee set to Julio Montoya

MMmm I will check this one

#4

Updated by Yannick Warnier over 9 years ago

  • Target version set to 1.9.2
#5

Updated by Yannick Warnier almost 9 years ago

  • Target version changed from 1.9.2 to 1.9.4
#6

Updated by Julio Montoya almost 9 years ago

  • Status changed from Assigned to Needs more info
  • Assignee deleted (Julio Montoya)

I can't reproduce the error in a new test created with Chamilo 1.9.4 (in repository) Probably the exercise comes from an old chamilo version?

#7

Updated by Alain Deschênes almost 9 years ago

Bonjour Julio,

As-tu essayé de créer plus qu'une question avec des accents?

Car une seule question avec accents ne pose pas de problème ...

Voir le quiz suivant créé sur la version en ligne pour tests tout en étant connecté en tant qu'admin :
http://stable.chamilo.org/main/exercice/overview.php?cidReq=AD2012&id_session=0&gidReq=0&exerciseId=5&preview=1

D'autre part, lorsque je crée ou modifie un quiz en tant qu'utilisateur adeschenes adeschenes - j'obtiens le message d'erreur suivant à la fin de l'édition de la question :

Forbidden

You don't have permission to access /main/exercice/admin.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.16 (Debian) Server at stable.chamilo.org Port 80

À plus,

Alain

#8

Updated by Julio Montoya almost 9 years ago

Alain Deschênes wrote:

Bonjour Julio,

As-tu essayé de créer plus qu'une question avec des accents?

non, je vais essayer

Car une seule question avec accents ne pose pas de problème ...

Voir le quiz suivant créé sur la version en ligne pour tests tout en étant connecté en tant qu'admin :
http://stable.chamilo.org/main/exercice/overview.php?cidReq=AD2012&id_session=0&gidReq=0&exerciseId=5&preview=1

oh oui j'ai vu le bug!

D'autre part, lorsque je crée ou modifie un quiz en tant qu'utilisateur adeschenes adeschenes - j'obtiens le message d'erreur suivant à la fin de l'édition de la question :

L'erreur 404 est "normal" parce que on met à jour les fichiers chaque 10-15 minutes avec la dernier version dans la repo (google code)

Forbidden

You don't have permission to access /main/exercice/admin.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.16 (Debian) Server at stable.chamilo.org Port 80

À plus,

Alain

#9

Updated by Julio Montoya almost 9 years ago

ca l'air de marcher dans mon serveur local, dans stable je vois l'erreur .... weird ...

#10

Updated by Julio Montoya almost 9 years ago

  • Status changed from Needs more info to Assigned
  • Assignee set to Julio Montoya
#11

Updated by Julio Montoya almost 9 years ago

  • Status changed from Assigned to Needs more info
  • Assignee deleted (Julio Montoya)
  • % Done changed from 0 to 10
#12

Updated by Alain Deschênes almost 9 years ago

Si on construit le test et on l'utilise, règle générale, tout se passe bien.

Maintenant, si on essaie de modifier la question, c'est là que ça ne fonctionne plus.

#13

Updated by Julio Montoya almost 9 years ago

  • Status changed from Needs more info to Assigned
  • Assignee set to Julio Montoya

ok, I got it

#14

Updated by Julio Montoya almost 9 years ago

je viens d'envoyer quelque changements

#15

Updated by Alain Deschênes almost 9 years ago

Excellent. Je teste sur me serveur ce soir et je te reviens pour la validation finale.

#16

Updated by Julio Montoya almost 9 years ago

  • Status changed from Assigned to Needs testing
  • Assignee deleted (Julio Montoya)
  • % Done changed from 10 to 80
#17

Updated by Alain Deschênes almost 9 years ago

  • Status changed from Needs testing to Bug resolved

Testé sur mon serveur et sur stable.chamilo.org - Tout fonctionne parfaitement.

Merci,

Alain

Also available in: Atom PDF