Project

General

Profile

Bug #3883

Portal unable to send email contact Administration

Added by Melissa Cadelina almost 9 years ago. Updated almost 8 years ago.

Status:
Bug resolved
Priority:
High
Assignee:
Bas Wijnen
Category:
-
Target version:
Start date:
09/09/2011
Due date:
% Done:

100%

Estimated time:
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

I am unable to send email both in the forgot password section and the send email to new users section.

I am using google apps and so I have my mail.domainname.com pointed to google. I have edited mail.conf.php and I have tried various log-ins in both gmail and my domain. I am certain that I am using the correct usernames and passwords. Is there any other options in being able to send mail using php-mailer when my domain is connected to google apps? I also do not have a domain right now that is not connected to google so I am unable to test that issue.

I am currently using chamilo 1.8.8.4 and this issue has come up both in a fresh installation and an upgrade. I have also tested this in two different shared hosting providers. I am using PHP 5.2.17 and mysql 5.0.92 (5.1.56 on the other).


Files

mail.patch (556 Bytes) mail.patch Bas Wijnen, 10/09/2011 08:17

Associated revisions

Revision d28832d7 (diff)
Added by John Hinojosa over 10 years ago

fixed - Add \"check box\" in question pool, issue #3883

Revision b4cdc367 (diff)
Added by Julio Montoya almost 9 years ago

Fixing api_mail function see #3883

History

#1

Updated by Bas Wijnen almost 9 years ago

  • File mail.patch mail.patch added
  • Status changed from New to Needs more info
  • Priority changed from Normal to High
  • Target version set to 1.9 Stable
  • % Done changed from 0 to 80

The problem is that there is a check to see if the address is valid, and it is only used if it isn't. Obviously this is not what was intended. A (one-line) patch is attached.

#3

Updated by Yannick Warnier about 8 years ago

  • Target version changed from 1.9 Stable to 1.9 Beta
#4

Updated by Yannick Warnier about 8 years ago

  • Target version changed from 1.9 Beta to 1.9 RC1
#5

Updated by Yannick Warnier almost 8 years ago

  • Status changed from Needs more info to Feature implemented
  • Assignee set to Bas Wijnen
  • % Done changed from 80 to 100
#6

Updated by Yannick Warnier almost 8 years ago

  • Status changed from Feature implemented to Bug resolved

Also available in: Atom PDF