Project

General

Profile

Bug #3788

Error on question copy

Added by Yannick Warnier almost 8 years ago. Updated almost 8 years ago.

Status:
Bug resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
08/08/2011
Due date:
08/08/2011
% Done:

100%

Estimated time:
0.75 h
Spent time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Minor addition: Inside the questions bank, make sure "All" is used instead of "0" in the "Difficulty" field and that it effectively selects all questions (currently it selects no question at all).

  • Go to http://chamilodev.beeznest.com as admin/admin
  • Get into "Periodismo de investigación" -> Ejercicios -> edit the only exercise -> go to question bank -> select "Seleccionar" for difficulty to view all questions.
  • Click on the copy icon (the CD)
  • Fatal error: Call to a member function updateTitle() on a non-object in /var/www/chamilodev.beeznest.com/www/main/exercice/question_pool.php on line 95 Call Stack: 0.0022 946352 1. {main}() /var/www/chamilodev.beeznest.com/www/main/exercice/question_pool.php:0

Expected result: the question should be copied inside my exercise...

It doesn't occur with all questions, but it can be repeated for existing questions.
Clicking on the first question doesn't generate an error, but the question copied is not the right one. I suppose there must be a "course code" parameter missing somewhere and that it's trying to copy the question number, but that question doesn't exist in the current course (first error), or that the question requested exists in the current course but obviously it is not the same question.

Associated revisions

Revision 585d23d4 (diff)
Added by Julio Montoya almost 8 years ago

Fixing pagination + all by default see #3788

Revision fde8c8d0 (diff)
Added by Julio Montoya almost 8 years ago

More fixes in the question pool should be fine now see #3788

History

#1

Updated by Julio Montoya almost 8 years ago

  • Status changed from Assigned to Needs more info
  • Assignee deleted (Julio Montoya)
  • % Done changed from 0 to 50
#2

Updated by Yannick Warnier almost 8 years ago

  • Status changed from Needs more info to Bug resolved
  • % Done changed from 50 to 100

Seems to have been fixed, indeed.

Also available in: Atom PDF