Project

General

Profile

Bug #3778

Char problem when using non alpha char on document title

Added by Hubert Borderiou about 8 years ago. Updated about 8 years ago.

Status:
Bug resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
04/08/2011
Due date:
% Done:

100%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

On chamilodev.beeznest.com

I've test creating a new document with name using the char ' (simple quote)
It results that the human name of my document replace non alpha chars with -
as for the filesystem name

Attached a screen copy of the problem with other non alpha chars
You can see on the top, my test line for folder and document name (without the single quote char )

I have to test with all chars because teacher likes to use every keys of there keyboard and copy/paste of Word text, with the Special Word Simple Quote, for instance (like the ALT+0180 : ´ )

(no problem with char ´ on chamilodev.beeznest.com)


Files

2011-08-04_1723.png (55.9 KB) 2011-08-04_1723.png Non alpha char problems with document title Hubert Borderiou, 04/08/2011 17:29
2011-09-23_1112.png (164 KB) 2011-09-23_1112.png Hubert Borderiou, 23/09/2011 11:12

Related issues

Related to Chamilo LMS - Feature #3781: Remove api_get_setting('use_document_title') optionFeature implemented05/08/2011

Actions

Associated revisions

Revision 6627a2b3 (diff)
Added by Julio Montoya about 8 years ago

Wrong document titles bug. Fixes #3778

History

#1

Updated by Hubert Borderiou about 8 years ago

Testing more these case, there is an error if there is chars

"<

in the title of a document. I can insert HTML code this way in my title.

If I create a folder with "< , the forlder name is just "

#2

Updated by Julio Montoya about 8 years ago

  • Status changed from New to Assigned
  • Assignee set to Julio Montoya
#3

Updated by Julio Montoya about 8 years ago

  • Status changed from Assigned to Needs more info
  • Assignee deleted (Julio Montoya)
  • % Done changed from 0 to 60
#4

Updated by Julio Montoya about 8 years ago

  • Status changed from Needs more info to Needs testing
  • % Done changed from 60 to 90

Applied in changeset r15315.

#5

Updated by Yannick Warnier about 8 years ago

  • Target version set to 1.8.8.4
#6

Updated by Yannick Warnier about 8 years ago

  • Status changed from Needs testing to Bug resolved
  • % Done changed from 90 to 100

works perfectly now, even with &é"'(§è!ç[] '= = µ ~ frf as a document name. You two (Hubert and Julio) make a great pair! :-)

#7

Updated by Hubert Borderiou about 8 years ago

Hi, I'm testing the chamilo 1.8.8.4
I try to name a new document
and I still have the issue if filename end with "<
or contain "< (with a space at the end eg : plop"< plop)

See screenshot of chamilo free campus today

regards,

Also available in: Atom PDF