Project

General

Profile

Bug #3777

Problem when creating a folder using chars : & > or <

Added by Hubert Borderiou almost 8 years ago. Updated almost 8 years ago.

Status:
Bug resolved
Priority:
Normal
Category:
-
Target version:
Start date:
04/08/2011
Due date:
% Done:

90%

Estimated time:
Complexity:
Normal
SCRUM pts - complexity:
?

Description

Hi, on http://chamilodev.beeznest.com
when I create a folder with char & > OR <
these chars are replace with there entities : & > and <

If I edit the folder properties I've got twice convertion of htmlentities : Le├žons &amp; Tests

Other characters are perfectly converted for folders


Files

2011-08-04_1711.png (77.5 KB) 2011-08-04_1711.png Hubert Borderiou, 04/08/2011 17:08
folder-funny-name-edit.png (15 KB) folder-funny-name-edit.png Yannick Warnier, 05/08/2011 18:22

Associated revisions

Revision 5d384102 (diff)
Added by Julio Montoya almost 8 years ago

Fixing bugs when creating folders see #3777

Revision 11a827d4 (diff)
Added by Julio Montoya almost 8 years ago

Fixing folder name bug see #3777

History

#1

Updated by Hubert Borderiou almost 8 years ago

I should have previzualized my post before commit it...
My entities has been replaced on my previous post, anyway, here is a screen copy of the issue

#2

Updated by Julio Montoya almost 8 years ago

  • Status changed from New to Needs more info
  • % Done changed from 0 to 70
#3

Updated by Yannick Warnier almost 8 years ago

  • Target version set to 1.8.8.4
#4

Updated by Yannick Warnier almost 8 years ago

  • Status changed from Needs more info to Bug resolved
  • Assignee set to Julio Montoya
  • % Done changed from 70 to 100

Tested and confirmed fixed.

#5

Updated by Yannick Warnier almost 8 years ago

I've spoken too quickly. When editing this directory, the form input box shows the HTML-escaped characters, see screenshot:

#6

Updated by Julio Montoya almost 8 years ago

  • Status changed from Assigned to Needs more info
  • Assignee changed from Julio Montoya to Yannick Warnier
#7

Updated by Yannick Warnier almost 8 years ago

  • Status changed from Needs more info to Bug resolved

Tested and approved.

Also available in: Atom PDF